The Diesel Stop banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2001 7.3 with 166,000. The truck has been harder and harder to start lately and then yesterday I started it and it ran for bout a min and shut off (this happen twice) but now when it does start it has a very rough idle. Any suggestions?

Sent from my Galaxy Nexus using AutoGuide.com App
 

·
Premium Member
Joined
·
14,604 Posts
Rough like running on half its cylinders rough? You could start it and let it run for a few seconds - then compare the exhaust manifolds on both sides - if one is cold, you likely have a bad connection on your under valve cover harness.

If its not that rough - could you give some more details as to what its doing?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I don't think its that rough. It shakes the whole truck like I'm n a race car. After it warms up a little its not as rough.

Sent from my Galaxy Nexus using AutoGuide.com App
 

·
Premium Member
Joined
·
14,604 Posts
Your truck would be a perfect candidate for an injector buzz test and a cylinder contribution test. Do you have access to AutoEnginuity? If not, where are you - someone close might have a scanner.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I had that done bout 6 months ago and it came back with a problem. Really can't remember what it was but I had it fixed. It don't act the same now as it was then when I had the problem.
 

·
Registered
Joined
·
1 Posts
Rough like running on half its cylinders rough? You could start it and let it run for a few seconds - then compare the exhaust manifolds on both sides - if one is cold, you likely have a bad connection on your under valve cover harness.

If its not that rough - could you give some more details as to what its doing?
im having that issue its loud and like half the motor isnt running? i was told to look for that exact thing and so far im only finding this extra bare wire wrapped around the whole harness conneting to the uvch. any idea as to where to look now? also have this white box on the trans tunnel that has rpm read out 6 buttons on it? what is? lol thx for any help.
 

·
Super Moderator
Joined
·
25,337 Posts
also have this white box on the trans tunnel that has rpm read out 6 buttons on it? what is? lol thx for any help.
That's likely an Auxiliary Power Control Module, also known as an engine idle controller. It's used to boost the idle speed for warm-up, or for power supply for heavy electrical loads like in ambulances.
Take RT's advice on the scan tool from above.
 
1 - 7 of 7 Posts
Top