The Diesel Stop banner

1 - 14 of 14 Posts

·
Registered
Joined
·
874 Posts
Discussion Starter #1
I just replaced all 8 injector, glow plugs, relays and fuel pump. I now get heavy grayish black smoke at start up and more smoke while driving. This was never an issue before. What could be the cause. Everything was replaced with OE parts.
 

·
Registered
Joined
·
2,227 Posts

·
Registered
Joined
·
874 Posts
Discussion Starter #3
I will set it back to factory tonight and see what it does in the morning. If it clears I will have some custom tunes made. I would hate for it to not be right after $3000 of work. The wife keeps telling me to sell it and I just might. I foundone with only a 105,000 miles on it today
 

·
Premium Member
Joined
·
14,988 Posts
How many miles have you put on it since the swap? You’ve got oil in the manifolds that has to burn off. Usually takes 100 miles t9 completely clear out. Less if you drive aggressively.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
618 Posts
Split shot injectors? Or single shots
 

·
Registered
Joined
·
874 Posts
Discussion Starter #6
Stock injectors, I went back to factory settings and it is still doing it. I will check fuel pressure and see if it is too high now.
 

·
Registered
Joined
·
2,227 Posts
Try driving 100 miles or so to see if it clears up. Maybe some oil got in there somewhere while the injectors were being installed and needs to get burned up.
 

·
Registered
Joined
·
874 Posts
Discussion Starter #8
I did I drove it from Texas too North Carolina after injector install
 

·
Registered
Joined
·
874 Posts
Discussion Starter #9
I hope I figure it out soon or the wife will put her foot down and make me but a new one. I have put back enough cash to get a new one but like watching the account grow instead of having a note or depleting savings.
 

·
Premium Member
Joined
·
14,988 Posts
Are you burning oil? Have you checked your fuel filter? You might have torn an o-ring going back in and now have oil getting into the fuel rail.
 

·
Registered
Joined
·
874 Posts
Discussion Starter #11
How many miles have you put on it since the swap? You’ve got oil in the manifolds that has to burn off. Usually takes 100 miles t9 completely clear out. Less if you drive aggressively.


Sent from my iPad using Tapatalk
I pulled 13,000 pounds to North Carolina from the Texas Louisiana border the day after the swap.
 

·
Registered
Joined
·
874 Posts
Discussion Starter #12
Are you burning oil? Have you checked your fuel filter? You might have torn an o-ring going back in and now have oil getting into the fuel rail.
Fuel filter is good
 

·
Registered
Joined
·
874 Posts
Discussion Starter #13
RT what should fuel pressure be
 

·
Premium Member
Joined
·
14,988 Posts
60-65 psi


Sent from my iPad using Tapatalk
 
1 - 14 of 14 Posts
Top