The Diesel Stop banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Truck is in my signature. Been to the dealership 3 times now for the same issue. Without trying to use 4wd the 4X4 light in the dash starts blinking. Most times it's at start up of the truck. The when it's doing this sometimes you can switch the 4x4 knob and it goes into 4wd and other times it does nothing and continues to blink. If you try and get it to shift while blinking it sometimes will stop working all together (like the TC is in neutral) and tonight it tried shifting into low range at 40 MPH (lots of grinding and banging) not good. The dealer has replaced the shift motor twice. The module that controls it once or twice, checked every connector pin and wire. They had it for a month over the summer, thought they had it this time? Of course now that it's winter and I need my truck the most and need 4wd it decides to take a sh!t again! Looking for some MAJOR help here. I know the tech at the dealership, he's tried everything and has a ton of time in it already and calls to Ford. Looking for something new to look for or someone who's had the same issue. Have had good luck with the truck other than this. This issue has been a total PITA! HELP PLEASE!
 

·
Registered
Joined
·
261 Posts
#1 do not try to put in low range while moving... thats a big no you need to have the truck in neutral and wait for the low range light to come on. #2 have you checked your vacuum? ESOF uses vacuum to lock hubs and the 4x4 wont engage without good vacuum. Also it sounds to me like the ESOF switch might be going bad or maybe your hubs are trying to lock for some reason. Have you thought about going to full manual hubs and avoiding the auto hubs all together? My experience has been that the auto hubs are not very reliable.
 
1 - 2 of 2 Posts
Top