The Diesel Stop banner
1 - 11 of 11 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter · #1 ·
Ok so I was driving and pulled up to stoplight. Truck just completely died,would no start. Almost acted like a timing issue. Would pop alittle and the started would grind. Took to my buddies shop where I have acces to snap on scanner. Pulled cam,crank sensor codes. Po611 and po0283. I hear a clicking coming from behind or around fuse box and it pops and grinds the starter/flywheel when it fired for s split second. If I disconnect Icp the clicking stops and it turns over no problem with no grinding. Get just a bit of white smoke outta tailpipe. Here is pics I took of scanner with koeo















 

·
Registered
Joined
·
151 Posts
Discussion Starter · #2 ·
Any help or if you guys need to see something please let me know. Iam I need to get this going it's my work truck and I've been down for two weeks ugh.thanks
 

·
Banned
Joined
·
22 Posts
Any help or if you guys need to see something please let me know. Iam I need to get this going it's my work truck and I've been down for two weeks ugh.thanks
Your FICM Low Power at 12.5 Volts seems ok, but your FICM Main Power at 47V seems a little low. Mine is usually at a steady 48.5 Volts.

P0611 FICM Fuel injector control module performance Internal FICM failure
P0283 INJ Cylinder #8 injector circuit high Circuit short to ground or voltage, fuel injector, FICM
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #4 ·
The icp and clicking behind fuse box has me stumped.i have access to all the tools to fix I just need to figure out what is going on.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #5 ·
New to scanners so I just don't know what parameters everything sho you l be at.
 

·
Registered
Joined
·
1,383 Posts
No, they are low. A 12 volt battery should read 12.6 volts when good and fully charged. Have your batteries fully charged and load tested. Check your cables and where the negative leads attach to the chassis on each side.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #8 ·
Here is some video of me trying to start with out Icp hooked up and with it.
 

·
Registered
Joined
·
151 Posts
Discussion Starter · #9 ·
Here is it with Icp hooked up. I also get I flicking under dash.


 

·
Registered
Joined
·
151 Posts
Discussion Starter · #10 ·
This one it shows Icp at over 1600 psi. I'm so confused. I can't even crank it over because it keeps grinding. If I disconnect Icp then it does crank with out grinding.

 

·
Registered
Joined
·
151 Posts
Discussion Starter · #11 ·
Any suggestions,truck is stuck at my friends shop and not sure what to do now .
 
1 - 11 of 11 Posts
Top