The Diesel Stop banner
1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello all. I have a International with a T444E (7.3).

I think I have a sensor telling the computer to back off the oil pressure to the injectors.

I am in the process of drilling my y pipe to tap a fitting to connect a boost gauge just to see what I have.

I have (2) sensors, one is threaded into the Y pipe that I think is a map sensor. I removed it and it looks like it senses pressure in the pipe. The other sensor is threaded in the pipe just past the air filter. The think I read somewhere that it is a temp sensor.

The truck is a dog until about 1900 rpm.

When the truck does not pull my oil pressure is about 2100 psi. at wot. When is runs decent, I have 2600 psi.

What sensors could be telling the computer to back off of the pressure until 1900 rpm?

New ICP, IPR, Injectors, CPS.

I would like to replace the map sensor but i think they are 120 bucks.

I have read that I can disconnect the map sensor (if that is what is threaded in the center of my Y pipe) and drive the truck to see if it runs better with out it connected.

My wastegate is manual, it has a rubber hose connected to the boost side of the turbo and activates a arm to open the gate. I think the gate is to open with 7 psi. I do not have a low regulator so I have a checked it yet.

Any help or guide me in the right direction would be greatly appreciated.

This is my work truck, when it does not work, I go broke. I am using the truck every day afraid I am going to damage it by running it.
 

·
Registered
Joined
·
2,473 Posts
The PCM tells the IPR to open/close for desired oil pressure. Do you have any codes? What's the IPR duty cycle at WOT?
 
1 - 2 of 2 Posts
Top