The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi! So I have a early 99 f350 7.3.
My hpop reservoir keeps draining, it drains while cranking it, I can manualy fill up the hpop reservoir and it will start. Will run q0 seconds and shuts off, and reservoir is empty.

So everything I've replaced related to this:
-LPOP
-Checked all the check balls
-replaced timing cover
-oil pickup tube is good
-Rebuilt the IPR
-Rebuilt my HPOP
-oil and filter changes
-replaced the non screen hpop res gasket

Took new lpop off, job was done correct no scoring on my new cover, packed with Vaseline.
 

·
Premium Member
Joined
·
15,241 Posts
The HPOP reservoir has a "standpipe" that drains excess LPOP oil back into the pan. I wonder if there was a crack in that part of the reservoir if it would drain like yours is doing. The check ball you mentioned is the one on the top of the motor? Any chance your rear oil cooler cover is missing the regulator or the bypass?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 · (Edited)
I just now seen this and just had a chance to get back under the hood. Yes the check ball on tohe block and in the hoop. I have my oil cooler back off now, everything appears to be okay in it. But I'm not real sure how to go about testing it? I have a clip holding the regulator that's still there. Do I need to just replace the whole oil cooler? Before I changed my front cover everything worked fine and it had full normal oil pressure, but once putting everything back together the res. Just KEEPS draining 😅

Thanks for your response and time. 🙏
 

·
Super Moderator
Joined
·
26,782 Posts
When you rebuilt the HPOP, did you also replace the gasket that seals it to the front cover? If not, a leak between the inlet and the gear opening would allow the oil to drain out of the reservoir.
 
1 - 5 of 5 Posts
Top