The Diesel Stop banner
1 - 20 of 117 Posts

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #1 ·
Some of you have might have noticed that I've had some problems.
I've tried the archoil products and it seemed to alleviate the problem but now they're back with a vengeance. What I'm feeling the van is doing, is on cold start up it has blue smoke way more than usual and has a very very bad vibration and doesn't go away until it reaches at least 175 degree oil temperature.
Even then it will stutter and vibrate while slow driving and puffs out Blue Smoke. I don't have a lot of money to fix this and I'm still on the road currently in New Jersey with no place to work.
She has some codes such as overboost I understand what that is and water in the fuel which I drained and hasn't come on since.

I have a sneaking suspicion it's the under cover valve harness going bad. What do you guys think is happening and how do I fix it???!

Thank you so much.
if anybody wants to call me directly please email me for my phone number.
[email protected]
 

·
Registered
Joined
·
17,604 Posts
Just my thoughts, but I don't think a failing UCVH would cause lots of blue smoke. Blue smoke is associated with burning engine oil. Maybe injector O rings?
 

·
Premium Member
Joined
·
1,639 Posts
bb, you've helped me many times, and I really wish I could offer suggestions for you now, but this is way beyond my expertise. Good luck.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #4 ·
Ok if it is injector O-rings or injectors what is involved in replacing them and can I do it quickly in a parking lot somewhere?
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #5 ·
I appreciate your thoughtfulness on commenting to help even though it's above your paygrade LOL
If you guys happen to know somebody who's good with Powerstrokes,please pass on my question to them and my email address if they think they can be helpful or beneficial.
 

·
Registered
Joined
·
230 Posts
Rob, lookup 'dieseltechron' on youtube and shoot him a message. He is definitely good about returning emails, even on the weekend. When my UCVH were loose, I experience the same symptoms but I can say for sure that you are also experiencing the same considering you have alot of blue smoke. This maybe associated with white smoke but have you checked your coolant reservoir for oil or diesel?
 
  • Like
Reactions: cjmcqueen1164

·
Premium Member
Joined
·
288 Posts
Bbasso, are you 100% sure it's blue smoke and not white smoke? Reason I'm asking is I had a helluva bad time with mine trying to diagnose what ended up being tank delamination. Early on, it was simply running rough sometimes. Then sporadic and usually fine on start up, but worse on a big uphill or with a load. Smoke looked light bluish white to me but I wasn't sure if the DieselCleen or other additives I used were throwing it off. Funny thing was that I later found out that fuel additives can worsen delam in van tanks!
 

·
Registered
Joined
·
936 Posts
Rob, lookup 'dieseltechron' on youtube and shoot him a message. He is definitely good about returning emails, even on the weekend.

DieselTechRon (Ron Huxell) was killed in a car accident the day before yesterday. What you report regarding his answering of emails, even from random strangers, even on the weekends, is further testament to the sad loss of another generous human being.
 

·
Premium Member
Joined
·
288 Posts
Rob, lookup 'dieseltechron' on youtube and shoot him a message. He is definitely good about returning emails, even on the weekend. When my UCVH were loose, I experience the same symptoms but I can say for sure that you are also experiencing the same considering you have alot of blue smoke. This maybe associated with white smoke but have you checked your coolant reservoir for oil or diesel?
FYI, DJ and everyone else, I just read confirmed reports over on the other forum, that Diesel Tech Ron was in a fatal wreck a few days ago. Of course, I hoped it wasn't true. He's done so much for the rest of us wannabe diesel techs over the years! He will be sorely missed by so many people he helped but never even met.
 

·
Registered
Joined
·
230 Posts
DieselTechRon (Ron Huxell) was killed in a car accident the day before yesterday. What you report regarding his answering of emails, even from random strangers, even on the weekends, is further testament to the sad loss of another generous human being.
FYI, DJ and everyone else, I just read confirmed reports over on the other forum, that Diesel Tech Ron was in a fatal wreck a few days ago. Of course, I hoped it wasn't true. He's done so much for the rest of us wannabe diesel techs over the years! He will be sorely missed by so many people he helped but never even met.
Wow, I had no clue! He will be sorely missed indeed. Very sad.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #11 ·
Yup, blue smoke but I also smell unburnt fuel when it's studdering and shaking.

Antifreeze is perfect, I've been checking each time I have driven.

I had my fuel tank down just a few month back and it was spotless, I hope this stuff doesn't make problems.
 

·
Registered
Joined
·
1,842 Posts
bbasso, if it were me, I'd check over in truck forums, & see if someone knowledgeable, is semi close to you, & give them a shout, to see if any guidance could be offered.
I once took off passenger side valve cover, & it took me a long time, I wasn't too happy doing it. With regret, I wish I knew ahead of time, for I would have replaced VC gasket with a new one. It was pretty much a waste of time, because I didn't know what I was doing anyhow.
 

·
Registered
Joined
·
19 Posts
Hi,
I had similar problem on my 2003 e350.
White/blueish smoke like crazy but also no power at all.
Max was 40mph on wot and then was smoking even more just like old steam ship.
I go to one mechanic and right away the told me...head gasket.
I didn't believe that so I go to diferent one(PDR diesel)and they change:
-ebp sensor
-ebp tube
-sensor harness(?)
-ipr valve
Believe or not this fix my problem!
No more smoking and power back.
Before that I bough new tank hoping that my tank is bad but my old one was totally fine.
So try checking all the sensors and good luck!
 

·
Registered
Joined
·
5,448 Posts
Where in NJ are you?
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #17 ·
Just as a precaution I changed the oil last night....
 

·
Registered
Joined
·
1,842 Posts
Just as a precaution I changed the oil last night....
Thats what I was thinking of telling you to do. Also maybe a buzz test, to see if there are any obvious dead injectors. I remember reading in truck forums, years ago of a guy having weird problems, & turned out to be a wire where it attached to injector.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #19 ·
I can do a buzz test later today or tomorrow when I download the app. I'll report afterwards.
 

·
Registered
Joined
·
1,369 Posts
Discussion Starter · #20 ·
I found a local diesel shop near by... said they would charge $95 for a diagnostics.
I've got a 1pm appt tomorrow.

Please chime in with any questions I should be asking them.
 
1 - 20 of 117 Posts
Top