The Diesel Stop banner
1 - 6 of 6 Posts

·
Registered
Joined
·
395 Posts
Discussion Starter · #1 · (Edited)
Rectangle Font Screenshot Operating system Parallel

Ran Buzz test repeatedly and got the same results
Swapped out IDM with a newly rebuilt one and now buzz test shows this
Rectangle Font Screenshot Technology Parallel

I've double checked resistance on these injectors at the IDM connector and I'm sitting right at 3.1 ohms.
Both UVCH replaced about 1 year ago. Not sure where to go from here but I'm supposed to take a couple of disadvantaged youth on a 5 hr trip to Carowinds tomorrow afternoon so I'd really like to get this figured out tonight if possible.
 

·
Premium Member
Joined
·
15,464 Posts
Any chance you have a buddy with a 7.3? I'd try a different IDM and see if that one creates codes.
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #3 ·
So it turns out the big list of codes shown in the first screen were stored codes. When I plugged the old IDM back in, and clear the DTCs, then both IDMs generate the same codes for #1 and #8. All injectors buzz nice and loud and the truck does run, just not very well. I ran the truck for a few minutes to bring it to the garage and ran some the cylinder contribution test. It throws a code for #2 cylinder. KOER test throws a code for injection pressure not as desired. After running these tests, I shut the truck off and ran the buzz test again. This time, no codes. I ran it a couple more times and no codes are generated. I've been all through this truck and just can't seem to figure out what's wrong. I've sent the PCM and IDM off to Diesel Tech if Chattanooga and both tested perfect. I just replaced the entire battery cable set and went through the chassis grounds because I was getting some high resistance to ground ( and I still do for some reason) I'm leaning towards an new harness next, but I don't really think that will fix the problem either.
 

·
Premium Member
Joined
·
15,464 Posts
So - no more IDM codes. A biased ICP sensor or chaffed wiring could be at fault. Does it run better with that sensor disconnected? Will your scanner allow you to monitor IPR duty cycle and IC pressure while you drive? Might be worth measuring that and posting your results.
 

·
Registered
Joined
·
395 Posts
Discussion Starter · #5 · (Edited)
Hi RT, sorry for the delay. We ended up taking the trip with the truck and it did fine until we got into a terrible accident.


 

·
Registered
Joined
·
746 Posts
Damn, I'm so sorry you had to go through that. I hope you are doing ok.
 
1 - 6 of 6 Posts
Top