The Diesel Stop banner

21 - 26 of 26 Posts

·
Registered
Joined
·
17 Posts
I had similar issues but cleaning the screens and replacing the tank and filters didn't fix it.... any ideas?
 

·
Registered
Joined
·
1 Posts
I to have similar issues. I turn the truck off for a few seconds (while driving) then pop start it, it seems to run for 3-7 minutes then loses power again. Feels like something is keeping fuel from circulating. I’ve changed the ICP, IPR, CPS, fuel filter, in tank pick up screen and 2 sock filters. Still doing the same thing. Fuel pump, maybe?
 

·
Registered
Joined
·
382 Posts
I'm always amazed at how good the help is in here.
 

·
Super Moderator
Joined
·
25,337 Posts
I had similar issues but cleaning the screens and replacing the tank and filters didn't fix it.... any ideas?
I to have similar issues. I turn the truck off for a few seconds (while driving) then pop start it, it seems to run for 3-7 minutes then loses power again. Feels like something is keeping fuel from circulating. I’ve changed the ICP, IPR, CPS, fuel filter, in tank pick up screen and 2 sock filters. Still doing the same thing. Fuel pump, maybe?
You both need to check your fuel pump.
Mark, your issue could be something else if you can just shut off and restart, but you should check your fuel pressure and delivery like ford_doctor suggested earlier in this thread.
 

·
Registered
Joined
·
17 Posts
I finally broke down and took it to the shop..... they said they found the problem twice..... it's still won't stay running and it's getting worse.... they said it's a short in the 5 volt system that communicates with the pcm... i ordered a whole new engine wiring harness... i am putting it in tomorrow..... never done this before wish me luck... open to advice as well...
 

·
Registered
Joined
·
4,867 Posts
You can replace the engine harness on a 7.3L with your eyes closed.
 
21 - 26 of 26 Posts
Top