The Diesel Stop banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just finished a top end rebuild. New heads, new injector pump, new injectors, new lifters, new glow plugs, new rocker arms. 1990 Ford E-350 7.3 idi. 300,000 miles. So after a few frustrating weeks, she is back together and seems to be running fine, EXCEPT.... you can hardly stand to be in the drivers seat when she starts up. When things get warmed up it sounds louder then before, but still sounds normal. It is on start up that it is really noisy and a little bit of a quiver (hesitation) when it is warming up. After a warm up, oil pressure normal, temp normal, everything seems ok on all gauges, but still a lot louder than it was before the rebuild. Should I be worried or just go with the wait and see?

Gary
 

·
Registered
Joined
·
1,842 Posts
Welcome to the forums, I dont know how many experts would see your post here, but if it were me, I'd post over in the truck engine forums.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks,
I don't know much about computers and a mostly have my wife post for me. I will post in engine forum. Appreciate the info.
 

·
Registered
Joined
·
1,842 Posts
I wasn't trying to scare you off, just trying to be more helpful. There doesn't seem to be much IDI talk in the vans here, maybe not many still running? Hope you find an answer/cure. This is the forum I was talking about 7.3L IDI Diesels (Not Power Strokes) - Diesel Forum - TheDieselStop.com Good luck, & wouldn't hurt to post back any results for future seekers as yourself.
 

·
Registered
Joined
·
2,945 Posts
Either That or PM Chuckster.....he has one .... although it is a Turbo but It still is an IDI .....
 
1 - 6 of 6 Posts
Top