The Diesel Stop banner

1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Fully deleted, Ez-lynk GDP tunned 120K . White smoked at idle after warm up and every stop light . Got home and it seemed to clear up until it idled for 30-40 seconds and the white smoke came back. Pressed the throttle in park and it bellowed white went to black . I continued to let it idle for a few minutes just to smell the exhaust (kinda smelled oil/fuel) was thinking the turbo seals.... let it idle and gave it a few taps on the throttle and went back and looked at the exhaust. Oil running out of the tailpipe. Need a sense of direction to look into . New to the 6.7, really familiar with the 7.3 and i am not afraid to get after this new one but i e never had anything like this .
 

·
Registered
Joined
·
4,675 Posts
Yup. You might want to pull the turbo for inspection and inspect the exhaust manifolds for wetness. You could still have a failure elsewhere sending coolant or fuel through the exhaust - it picks up the carbon and looks just like oil most of the time.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
No coolant loss, i feel it is too thick of fluid to have any fuel mixed in. Smells like oil and nothing else.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Almost ready to pull the turbo, I know there is suppose to be an oil film on the cold air side of the intake plenums but i found it to be pretty soaked and the turbo veins are soaked also. The shaft of the turbo has up/down, side/side play in the shaft but not in and out. Still thinking the seals in the turbo are what went bad . That's my thought anyways
 

Attachments

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Turbo off late last night . No oil in the up pipes only in the down pipe. My conclusion is the seals are gone . Any recommendations on a drop in replacement?
 
1 - 7 of 7 Posts
Top