The Diesel Stop banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a1997 F250 7.3L powerstroke diesel that has a sound that the engine is mis-firing or skipping at the bottom line on the temperature gauge. It runs fine till you hit that temp once that temp raise above the truck runs fine. It's a small window of time that runs like that. Just had the turbo tower replace. The truck has 258k.Thanks in advanced for any help. Roundtrip
 

·
Registered
Joined
·
1,089 Posts
Sounds like what we call the "romps". Does it for a few seconds up to a minute or so after a cold start. Just the oil pressures building and settling in.
AaronSEIA
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Aaron, this never happened before. It started after the turbo tower was replaced. It seem like is not getting enough fuels. Could a fuel injector be going bad. Roundtrip
 

·
Registered
Joined
·
1,089 Posts
Might not hurt to double check all the harness to the heads. It's possible that something got jarred loose doing the turbo pedestal swap. I think it'd be one heck of a coincidence to have injectors fail at the exact same time you did the pedestal. Why exactly did you swap it?
AaronSEIA
 

·
Registered
Joined
·
4,976 Posts
I agree check a lot of other stuff before you think of injectors. I had a 96 that did not like 15-40 in the winter, went to 5-30 and ran like a top.
DENNY
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Aaron, it was leaking oil. I brought the truck back to the dealer and they said they could not find anything wrong. Thank every one with your comments.
 
1 - 6 of 6 Posts
Top