The Diesel Stop banner

1 - 15 of 15 Posts

·
Registered
Joined
·
829 Posts
Discussion Starter #1
My truck was running fine and lost power and started missing. I limped it home my icp reads 460-500 psi at idle and 1250psi at 3,000 rpm. The ipr was 7.52% at idle and fuel pressure is at 54psi.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #2
I have a new ipr and icp in the glove box so I guess I will start their.
 

·
Super Moderator
Joined
·
25,439 Posts
Did the SES light come on? Start by getting codes pulled.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #4
No light had p1211
 

·
Registered
Joined
·
829 Posts
Discussion Starter #5
I am about to go run live data while driving and watch icp & ipr to see what is going on.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #6 (Edited)
I just drove it and it was fine till it got up to temp then it feel on its face. Before it got hot idle to under load icp .69v-.85v 460psi-2700psi. The ipr 5-35%

Once it warmed up icp .8-3.9v 500-1800psi ipr was 9-92%
Also ran codes p1280,p1211,p0238, & p0475
 

·
Super Moderator
Joined
·
25,439 Posts
Check your fuel delivery. Where are you reading fuel pressure from? Could be that your filter is clogged and you're only getting that 54 psi on the tank side of the filter and much less on the injector side.


A lack of fuel can cause a P1211 code.


I can give you more things to look at based on your codes later. P1280 can be caused by an unplugged ICP sensor or a problem with the wiring to it. I would check that also.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #8
I did 50psi good fuel pressure coming of the fuel bowl with a Gage.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #9
Plus it only happens once the truck gets up to temp. I just hope it is not something with injectors. I am in the middle of remodeling the house. I don't need a Big job.
 

·
Super Moderator
Joined
·
25,439 Posts
Plus it only happens once the truck gets up to temp.
You might try unplugging the Engine Oil Temp sensor on the back of the HPOP reservoir. There's a slight chance it might be affecting the ICP signal. My vote is on a wiring issue, though.


Here's some info on the two ICP codes.

  • DTC P1209 and P1211 indicates that injection control pressure was above or below desired level under normal driving conditions.
  • Possible causes:
    • incorrect oil or viscosity
    • poor oil quality
    • gel fuel/no fuel
    • low fuel pressure
    • damaged IPR valve
    • high-pressure oil system leak
    • damaged high-pressure oil pump
    • damaged PCM


  • DTC P1280 indicates injector control signal circuit out of range low was detected during KOEO Self Test or during continuous diagnostic monitoring.
  • Possible causes:
    • biased ICP sensor/PCM
    • open ICP sensor circuit
    • short to SIG RTN or PWR GND on ICP sensor circuit
    • open in VREF circuit
 

·
Registered
Joined
·
829 Posts
Discussion Starter #11
Thanks for the help. It ended up being the icp sensor and pigtail. I changed it and running like a champ.
 

·
Registered
Joined
·
829 Posts
Discussion Starter #12
Thought I had it fixed but it is doing it again. Going it is just the cheap after market sensor. Will replace it again tonight after checking codes and reading live data
 

·
Registered
Joined
·
829 Posts
Discussion Starter #13
I am starting to think my problem might be with uvc harness or injector o- rings On my injectors
 

·
Registered
Joined
·
829 Posts
Discussion Starter #14
The issue ended up being the ipr. I had changed the screen in the hoop reservoir and some junk must hand got in the ipr.
 

·
Registered
Joined
·
941 Posts
Glad you got her figured out. Thanks for posting the end result!
 
1 - 15 of 15 Posts
Top