The Diesel Stop banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2008 6.4 F-250, When I start the truck the 4hi and 4low lights come on and cycle but thats all. When the selector is moved there is nothing that happens. I have ohm'd the switch and all is well, I have checked all the related fuses and all are good, I have verified voltage and again all seems to be good. this is really stumping me as I just bought this truck in March and shame on me for not checking this but I somehow let it slip my checks before purchasing so shame on me.. But I hoped that before I take it somewhere that maybe someone here had some input...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Just an update, I have since replaced the Trangercase motor, vacuum actuator, all vacuum lines, and the switch on the dash. Because the new motor came in 4Hi I had to manually put the tcase in 4Hi so now, it’s stuck in 4Hi… nothing seems to work.. I am in the same pace I was when I started ..
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
I have also swapped relays and checked all fuses again to no avail.. I am starting to wonder if it may be the 4x4 module to which I don’t know how to test… I am not getting any power to the transfer case motor..
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Update!!

Under the fuse box under the hood I found multiple wires that had rubbed through, one of which went to the the relay and the other two went to the Transfer case motor. I repaired all the wires and I'm back in action. I found it extremely hard to find much information on the 2008-2010 F-250's.. So I hope this thread helps someone and they don't have the same headaches I have had this week..

Best Regards,
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top