The Diesel Stop banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Here is the truck: 2004 F-250 6.0 with an airaid intake system a MBRP turbo back 4 inch exhaust with dual 6 inch stacks no cat. No tuner yet everything else stock. I recently did an EGR delete and replaced all of my injectors. I noticed after the recent work I have lost the jet sound from the exhaust. I am still getting boost which I am monitoring with a scan gauge ll. Any ideas out there? I am sure this has been asked before and hope there was a cure to my trucks ailment.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
I went and checked all connections which seem secure and well seated. No loss of power that I can tell. A friend says maybe an exhaust leak but I would think I'd hear that somewhere else and I don't.
 

·
Registered
Joined
·
6 Posts
Yeah...I agree. Even a small leak is very noticeable. If it was fine before I'd bet it's something simple. Maybe the vgt wires got pinched?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
I did see the sheathing for the vgt wires torn open but didn't check the wires (duh). I am going to check these wires more closely. I hope this is it. Thanks for the input so far I appreciate it very much. I will update you when I know more. Sorry I am not responding directly to a comment I am still figuring this out. Thanks again.
 

·
Registered
Joined
·
24 Posts
When i had my 6.0 it burned alot of oil after awhile if i let it go a little too long it would lose the jet sound to it... top off the oil and it came right back

Sent from my SM-G900P using Tapatalk
 

·
Registered
Joined
·
24 Posts
When was the last time the turbo was cleaned? I know gunking up was notorious also.

Sent from my SM-G900P using Tapatalk
 
1 - 9 of 9 Posts
Top