The Diesel Stop banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi All
I have a 1993 Ford E350 7.3L It will not start it will fire if you spray diesel fuel in intake, I replaced fuel pump . still nothing, I checked pressure line just before injection pump its fine. I checked fuel getting to injectors , its not spraying fuel to injectors, I unplug wire for injection pump cut off its getting power to the cut off solenoid it clicks. the engine light is not on. is it bad injection pump , I have no code reader to see if giving any code..
 

·
Registered
Joined
·
17,604 Posts
Your not going to get any codes, so dont bother trying.

First thing is to check the glow plugs. If any of them are bad, change them all. Use only mororcraft plugs. You can use Wellman just DONT use Autolite. Next is battery(s) need to be up to snuff to spin engine at least 300 RPM. Then check for fuel pressure at the filter header. 4-7 PSI using schrader valve fitting.

At cranking RPM, very little fuel is sent to injectors so you may not see much. Post back after checking what I’ve suggested and we can go from there.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
has new batterys bought month ago, has new glow plugs also. I ran fine . one morning I started it it ran for min. them stalled had no fuel pressure so I put new fuel pump , now it has fuel pressure
 

·
Registered
Joined
·
1,649 Posts
Check power to the fuel shut off solenoid, and that it operates. Also check power to the glow plugs...while they're cycling. I checked one with the system off all ok still couldn't get anything, checked with the system active, nothing. Turned out to be the fusible link.
 
1 - 4 of 4 Posts
Top