The Diesel Stop banner

1 - 5 of 5 Posts

·
Registered
Joined
·
250 Posts
Discussion Starter #1
Probably beat to death but i couldnt find a thread with my exact symptoms.


Got a new truck having some issues its a late 99 7.3. There is no oil in the coolant checked that out. I got back from a 300 mile trip and discovered i lost about 3 quarts of oil. Its got 1 oil leak in the front of the engine somewhere it leaks on the tie rod. I dont think i lost it all there though it dripps pretty slow. It does smoke under throttle however and is hard to start in the morning. Im guessing it burns oil. Has some blowby but not alot of pressure on my hand and dosent blow the cap off. The fuel in the bowl is bluish but i added 2 strok oil in that tank of fuel. Im guessing turbo seals or injector o rings. Is there any way to tell between the two or should i just do both rebuild the turbo and put o rings on the injectors? The injectors arent the greatest it runs pretty bad until warm. Another thing to mention is it stalls when i downshift if i dont give it some fuel. Only when i downshift though. It almost stalls when i go from 2000 rpm and let off the gas at idle. HPOP?
 

·
Registered
Joined
·
500 Posts
Probably beat to death but i couldnt find a thread with my exact symptoms.


Got a new truck having some issues its a late 99 7.3. There is no oil in the coolant checked that out. I got back from a 300 mile trip and discovered i lost about 3 quarts of oil. Its got 1 oil leak in the front of the engine somewhere it leaks on the tie rod. I dont think i lost it all there though it dripps pretty slow. It does smoke under throttle however and is hard to start in the morning. Im guessing it burns oil. Has some blowby but not alot of pressure on my hand and dosent blow the cap off. The fuel in the bowl is bluish but i added 2 strok oil in that tank of fuel. Im guessing turbo seals or injector o rings. Is there any way to tell between the two or should i just do both rebuild the turbo and put o rings on the injectors? The injectors arent the greatest it runs pretty bad until warm. Another thing to mention is it stalls when i downshift if i dont give it some fuel. Only when i downshift though. It almost stalls when i go from 2000 rpm and let off the gas at idle. HPOP?


I would check the glow plugs make sure they are in good working order. If the glow plugs and batteries are in order then it could be worn injectors or worn o rings on the injectors. I would get a injector buzz test done that will help tell you if you have warn injectors. The turbo can burn oil you can have the stock one rebuilt with updated 360 degree thrust bearing and a wicked wheel for 500-800 bucks or drop in a Gtp38r turbo or a KC 38r turbo they run 1300-1600 bucks.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
250 Posts
Discussion Starter #3
I would check the glow plugs make sure they are in good working order. If the glow plugs and batteries are in order then it could be worn injectors or worn o rings on the injectors. I would get a injector buzz test done that will help tell you if you have warn injectors. The turbo can burn oil you can have the stock one rebuilt with updated 360 degree thrust bearing and a wicked wheel for 500-800 bucks or drop in a Gtp38r turbo or a KC 38r turbo they run 1300-1600 bucks.


Sent from my iPhone using Tapatalk
Ok im planning on putting glow plugs in before winter anyway. My brother in law works for power ford so ill have him buzz test it and scan for codes. Ive rebuilt the turbo in my 2001 so im not afraid to do it to my 99. Ill start there. Thanks.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #4
Figured out all my problems just now. Its a bad motor. I took the ccv and vented it to atmosphere because i found oil all over the filter. Me thinking it was how i routed it but nope. I ran it over the alternator then took it for a spin and found oil everywhere. So its got to much blow by im assuming. Im going to swap the trans into my other auto truck and keep the motor to rebuild. Any tips or pain in the butt things people ran across when swaping to 6 speed? I can handle the swap its not a big deal but any info is welcome. Thanks!
 

·
Registered
Joined
·
250 Posts
Discussion Starter #5
... Motor blew up. :grin2: was coming home from work and it lost power and sounded like bad lifters then came a very loud knock sounds like something hitting the oil pan. Bunch of rattling in the exhaust. ect. So it decided for me the crew cab gets the 6 speed.
 
1 - 5 of 5 Posts
Top