The Diesel Stop banner

1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I'm throwing the code P040D, which looks to be related to an EGT sensor. All's well, I've spoken with Ford and I'm going to take it in under warranty in a few days. The problem is that every since I've returned to stock from my Edge Evolution (as I always do before service, just in case) the check engine light has went off and hasn't came back on for 3 days now. I have virtually no power at times when pulling a hill. We all know how much we hate the words "could not duplicate problem" on the service invoices from Ford. Does anyone think they can still pull the code if the light fails to come back on before I get it to the shop? My past experience tells me that they won't check the EGT sensor just because I tell them I did my research and I believe it to be the problem. Any help is much appreciated.
 

·
Registered
Joined
·
1,172 Posts
Best advice I can give ya is to stop jackin your dealer around by erasing codes with your programmer. Wait for the light to come on, leave it alone, and take it in for repairs.
 

·
Registered
Joined
·
613 Posts
95% chance EGT A is biased at times. I've seen programming cause this DTC when EGT's get too high (still at safe levels) during rapid acceleration or heavy load on the engine. Your best bet is to avoid any future issues by leaving the Evolution off, duplicating the concern, and taking it in. I'd suggest leaving it off unless you've got deep pockets. There are indicators stored in the ECM that programming was used, that normal dealer techs cannot detect, but the field service engineers have software that can. Suppose your HP fuel pump took a crap, wiped out the fuel system, and an inexperienced dealer thinks this "dosen't happen all the time" and gets the FSE involved. The second he plugs his laptop into your truck he'll know.
 

·
Registered
Joined
·
60 Posts
Our techs don't like chargebacks.... They use OASIS quick start often. Ever notice how the lights on the laptop go crazy when you do that?

Most of us are "mod-friendly" to a point. Lie to us and we can get real nasty real fast.

Speaking of mods, and I'm sorry to get off topic... how do you feel about K&N type air filters?
 

·
Registered
Joined
·
55 Posts
I had the same issue at about 50k, I replaced EGR sensor "A" behind the passenger side fender cover, not to hard to do, $60.00 part and about 1/2 hour, the only tricky part was doing re-attaching the electrical socket I found a thread on this fourm that shows pictures of the location.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Ford fixed it under warranty in less than 30 minutes. I also had a great conversation with some of the guys regarding a lot of the issues with the 6.4. I was impressed, as it was the most helpful information I've received yet. @ djshum- As far as jacking my dealer around, really? I simply stated that the check engine light went off upon unplugging the Edge. I'm pretty sure this forum is meant to help others and discuss problems, not criticize them for the use of programmers, seeing as how 80% (+/-) of us are probably using them. On top of that, most of us are probably responsible users as well. I'm well aware of the adverse affects caused by the misuse of programmers.
 

·
Registered
Joined
·
1,172 Posts
Ford fixed it under warranty in less than 30 minutes. I also had a great conversation with some of the guys regarding a lot of the issues with the 6.4. I was impressed, as it was the most helpful information I've received yet. @ djshum- As far as jacking my dealer around, really? I simply stated that the check engine light went off upon unplugging the Edge. I'm pretty sure this forum is meant to help others and discuss problems, not criticize them for the use of programmers, seeing as how 80% (+/-) of us are probably using them. On top of that, most of us are probably responsible users as well. I'm well aware of the adverse affects caused by the misuse of programmers.
"We all hate the words 'could not duplicate problem' on service invoice" REALLY?......I don't care what you do with YOUR vehicle. Don't complain about the dealer not being able to make a repair due to "could not duplicate problem" when your the one clearing the codes and concern is not actively present....just saying. I gave you advice, on your problem, because that's what this forum is for as you stated, it wasn't criticism. Your post sounds as though your criticizing the dealer for your own actions. Good luck with your repairs.
 

·
Registered
Joined
·
60 Posts
Ford fixed it under warranty in less than 30 minutes. I also had a great conversation with some of the guys regarding a lot of the issues with the 6.4. I was impressed, as it was the most helpful information I've received yet. @ djshum- As far as jacking my dealer around, really? I simply stated that the check engine light went off upon unplugging the Edge. I'm pretty sure this forum is meant to help others and discuss problems, not criticize them for the use of programmers, seeing as how 80% (+/-) of us are probably using them. On top of that, most of us are probably responsible users as well. I'm well aware of the adverse affects caused by the misuse of programmers.
The check engine light is going to go off when you unplug the edge.... You are disrupting keep alive memory by unplugging it. This is the way it is. Without realizing it, you are one of the causes of your own concern


Here is how it will go in a warranty situation. You will bring me your truck. It will have a situation where I have to report "no problem found" - or it will have a situation I can work with.

If you unplug your edge and drive it until the concern happens again, we have a fighting chance of getting to the bottom of the situation (please note - I avoided saying "fix"). I have seen as many problems caused by faulty chips (possibly more) as caused by conditions with the base engine.

To avoid wasting my time and yours, we need to establish if the concern is with the base engine or related to using the programmer/chip/whatever.

FWIW, there is no animosity intended in this reply... I am simply stating facts.

To all... Ford is (now with the advanced electronics on the 6.7, I can't be sure) trapped into having to prove that your chip is that cause of the problem. At the same time, the chip is going to alter data readings that the tech needs to diagnose your concern. If you run a chip, have the balls to tell the tech "I run a chip". Tell him when it was last disconnected ( there is a PID for the distance driven since the last memory clear)... help him.. disconnect the tuner and drive it to see if the concern comes back. If it doesn't... well, common sense might have to come into play.

Ford will pay to diagnose Fords issues... they wont pay to diagnose Edges issues.
 

·
Registered
Joined
·
60 Posts
Ford fixed it under warranty in less than 30 minutes. I also had a great conversation with some of the guys regarding a lot of the issues with the 6.4. I was impressed, as it was the most helpful information I've received yet. @ djshum- As far as jacking my dealer around, really? I simply stated that the check engine light went off upon unplugging the Edge. I'm pretty sure this forum is meant to help others and discuss problems, not criticize them for the use of programmers, seeing as how 80% (+/-) of us are probably using them. On top of that, most of us are probably responsible users as well. I'm well aware of the adverse affects caused by the misuse of programmers.
The check engine light is going to go off when you unplug the edge.... You are disrupting keep alive memory by unplugging it. This is the way it is. Without realizing it, you are one of the causes of your own concern


Here is how it will go in a warranty situation. You will bring me your truck. It will have a situation where I have to report "no problem found" - or it will have a situation I can work with.

If you unplug your edge and drive it until the concern happens again, we have a fighting chance of getting to the bottom of the situation (please note - I avoided saying "fix"). I have seen as many problems caused by faulty chips (possibly more) as caused by conditions with the base engine.

To avoid wasting my time and yours, we need to establish if the concern is with the base engine or related to using the programmer/chip/whatever.

FWIW, there is no animosity intended in this reply... I am simply stating facts.

To all... Ford is (now with the advanced electronics on the 6.7, I can't be sure) trapped into having to prove that your chip is that cause of the problem. At the same time, the chip is going to alter data readings that the tech needs to diagnose your concern. If you run a chip, have the balls to tell the tech "I run a chip". Tell him when it was last disconnected ( there is a PID for the distance driven since the last memory clear)... help him.. disconnect the tuner and drive it to see if the concern comes back. If it doesn't... well, common sense might have to come into play.

Ford will pay to diagnose Fords issues... they wont pay to diagnose Edges issues.
 

·
Registered
Joined
·
1 Posts
I too am having the same code P040D I have replace the sensor on the tube to behind passage side head the egr vale, egr temp sensor and even one in the exhaust. before each replacement I put my scanner on and erase the codes and today I have the code aging P040D. I have no acceleration at all. the truck will go but no power. I replace the fuel filters last oil change just saying for someone told me that may be the problem. Can some one give me some info and peace of mine I even went looking for a new truck today for I am at my wits end!!
Thanks
Ray Rice
[email protected]
 

·
Registered
Joined
·
1 Posts
I too am having the same code P040D I have replace the sensor on the tube to behind passage side head the egr vale, egr temp sensor and even one in the exhaust. before each replacement I put my scanner on and erase the codes and today I have the code aging P040D. I have no acceleration at all. the truck will go but no power. I replace the fuel filters last oil change just saying for someone told me that may be the problem. Can some one give me some info and peace of mine I even went looking for a new truck today for I am at my wits end!!
Thanks
Ray Rice
[email protected]
Hello Ray,
Did you figure out what the problem was? I’m experiencing the same symptoms with loss of power. I’m taking my 08 6.4 to get EGR & DPF deleted next week, hope it gives me better performance.
 
1 - 11 of 11 Posts
Top