The Diesel Stop banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Just got 1988 F350 7.3 idi it has sat for years cleaned the tanks back tank is out of it we have the sending unit tied up out of the way and capped off. The front tank was cleaned completely cleaned out and put back in replaced all glow plugs, the relay and the control, new injector kit, new starter, new batteries, lift pump, water pump, and new fuel filter. It still doest wanna start have to crank and crank if it does start it only runs for a bit and dies! It started off fine then as I was driving it the fuel filter light would come on and it would act like it didnt have the fuel to go, then it would shake and then jump back up. I looked at the filter didnt see anything still replaced it, it did it again and i was told to get rid of the bottom cap (the water separator) did that got a normal filter with the valve on the bottom. I have bleed the lines all they do is bubble! next step i think is to replace all lines if that doest work new pump too unless someone could point me in the right direction PLEASE I am going nuts!!
 

·
Registered
Joined
·
1,876 Posts
Sounds like it's sucking air.
So replace the rubber line between the frame and lift pump. Also replace the lift pump itself.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
the lift pump is new just did that this week, in the morning i will start with all the lines. thanks again!
 

·
Registered
Joined
·
1,876 Posts
Although it's not as common, if you didn't get the pump arm on the right side of the shaft, usually the arm breaks off.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
that is the first thing i check was the hose coming off the pump and it is flowing good. i checked the fuel filter and that is staying half full so i would have to assume air is getting in some where.
 

·
Registered
Joined
·
8 Posts
that is the first thing i check was the hose coming off the pump and it is flowing good. i checked the fuel filter and that is staying half full so i would have to assume air is getting in some where.
Have checked your fuel solenoid shut off on the pump? Could possibly be shuttering open and shut and causing a vacuum to the pump and letting air to the injectors. Does it rev up and down any without touching the accelerator? If so that would guarantee that you have air intrusion vs fuel starvation.
 

·
Registered
Joined
·
1,847 Posts
I would look for air imtrusion. Remember air can get in when fuel can't get out. look at the supplylines, and the return system. Is your tank selection valve sealing off all the way? With one tank not even there that might be a prime spot for air to get in.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
got it running my wife went out and ran all new lines and we bleed the crap out of it and she starts like a champ! just have to find out the new problem the coolant gauge isnt working lol thanks for all your help guys!
 
1 - 9 of 9 Posts
Top