The Diesel Stop banner
21 - 40 of 50 Posts

·
Super Moderator
Joined
·
26,785 Posts
One thing that hasn't been said here is how much the trailer weighs.
An extremely heavy trailer would pull speed down pretty quickly on an uphill grade.
 

·
Super Moderator
Joined
·
26,785 Posts
Is that gooseneck empty or hauling two pickups on it? It makes a difference.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #25 ·
The last time I was loosing power pulling a hill with a 32' 5th wheel trailer behind me it was my exhaust backpressure sensor was plugged my truck is a 95 not sure on the 99 and ups. If you have one it is located on top of the front of the engine close to the alternator you will see a stainless or copper tube coming from the sensor going to the front of your passenger side exhaust manifold. When mine was loosing power I had no check engine light and no codes were stored I just noticed the truck was struggling to pull when I hit the hill. I was showing boost but, it wasn't what it should have been. It won't cost you any money to pull the sensor off and clean it no, need to replace as they rarely ever go bad. I had almost 1 million miles on the original sensor I would just pull it off every couple years and clean it. To clean it pull it off turn it upside down use a small eyeglass screwdriver stick it in there and gently scrape it around turn it over a tap it on a hard surface into a paper towel you will see the black carbon crud that builds up. Then take some brake kleen or starting fluid and spray it in there tap it out spray some more in there scrape around with the screwdriver tap it out. Do it a few more times and before you put it back in look down into the tube and see if it has build up inside the opening if it does scrape it with the screwdriver and start up the truck with the sensor off and it will blow out the crud and yes, it will turn on the check engine light. Put the sensor back in and try to pull your trailer again hopefully, it will. Unless, you have a scanner you will need to disconnect the batteries for about 10min to turn off the check engine light. Not sure if it is your problem but, like I said it is free to try. Good Luck! and keep us posted.
So I clean the ebp sensor n put a new map sensor on it and it still have no power going up hill while under a load
 

·
Registered
Joined
·
667 Posts
I'm running out of suggestions, have you pulled your air intake off going into the turbo and looked at the impeller for wear and play? When you look at the impeller the edges should be nice and squared off not rounded which would indicate dirt and such made through your air filter as far as play there should be no up and down or side to side or very minimal. When he had his computer hooked up and downshifted with the trailer on it going up hill. How much boost did he see? On my 95' with a load on I can see as much as 20-23 maybe a little more it's been awhile since, I have had a load that worked my truck. Have you checked the brakes and wheel bearings on your truck and trailer to make sure they aren't dragging? If you have a laser temperature gun you could drive it with the trailer hooked up and stop and point it at the wheel hubs and see if one of them is running much hotter. I did have that happen too me on a customers 5th wheel that I was pulling cross country.
 
  • Like
Reactions: Greg687

·
Registered
Joined
·
511 Posts
Great thought... brake controller or trailer brake issue?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #28 ·
I'm running out of suggestions, have you pulled your air intake off going into the turbo and looked at the impeller for wear and play? When you look at the impeller the edges should be nice and squared off not rounded which would indicate dirt and such made through your air filter as far as play there should be no up and down or side to side or very minimal. When he had his computer hooked up and downshifted with the trailer on it going up hill. How much boost did he see? On my 95' with a load on I can see as much as 20-23 maybe a little more it's been awhile since, I have had a load that worked my truck. Have you checked the brakes and wheel bearings on your truck and trailer to make sure they aren't dragging? If you have a laser temperature gun you could drive it with the trailer hooked up and stop and point it at the wheel hubs and see if one of them is running much hotter. I did have that happen too me on a customers 5th wheel that I was pulling cross country.
I had it in 2 shops n they are licensed so I wouldn’t see how they couldn’t fix the problem that’s going on but I do here sum noise cumin from the driver side I changed the hub on both side n still hear a roar wen iam going down highway just a little bit I notice my tire was ate up on the inside so iam think the sound is coming from tire cuz I need front end Alinement I guess… but another thing I didn’t do that iam going to do today I just took the ebp sensor off I didn’t take the line off it could have a hole in it n another thing I was thinking it was my under valve cover harness that make it does that like I said the truck run fine no check engine lights on it ride up a hill fine wen I dnt have my trailer on but wen I put it on n put a weight on the trailer that’s wen it start to drop speed wen iam going up hill I give her gas n she does nothing I can floor it n she does nun but once I’m on flat ground she drive fines I can floor it n it does fine
 

·
Registered
Joined
·
667 Posts
Are you able to remove the performance tune that they put in? Yeah, it wouldn't hurt to check the EBP tube for a pinhole but, I would think it probably wouldn't unless you have the old copper tube like I did. I saw a green spot on my tube and I went to rub that spot with my fingernail and sure enough there was a hole. I changed it out to a stainless tube and I would think that the newer trucks all have the stainless EBP tube. Since, it only looses power with the trailer hooked up is why I suggested to also, check that your trailer brakes aren't dragging or that something isn't wrong with the brake controller. I would still pull your intake tube off going into the turbo to check it for wear and play just because, they see 15psi boost doesn't mean that the turbo can't be worn and tired. Like I said if I work my truck with a heavy load I can see 20-23 psi boost no, problem maybe a little more. At least these suggestions won't cost you money to check them out it sucks to keep throwing parts at and not get anywhere I have been there and done that. I will always start with the cost free checks first and if I can't figure it out then I will take it to my trusty mechanic he is the only one that I will let touch my truck when I'm home. Like someone else, said the mechanic that suggested you need more HP and to put a tune in it is a mechanic I wouldn't go back too these trucks are more than capable to pull heavy loads without a chip. You even said before this happened you had no, problems pulling your loaded trailer before and you didn't have a tune in it. Adding a tune for more power is nice but, it is not the answer to your problem.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #32 ·
Are you able to remove the performance tune that they put in? Yeah, it wouldn't hurt to check the EBP tube for a pinhole but, I would think it probably wouldn't unless you have the old copper tube like I did. I saw a green spot on my tube and I went to rub that spot with my fingernail and sure enough there was a hole. I changed it out to a stainless tube and I would think that the newer trucks all have the stainless EBP tube. Since, it only looses power with the trailer hooked up is why I suggested to also, check that your trailer brakes aren't dragging or that something isn't wrong with the brake controller. I would still pull your intake tube off going into the turbo to check it for wear and play just because, they see 15psi boost doesn't mean that the turbo can't be worn and tired. Like I said if I work my truck with a heavy load I can see 20-23 psi boost no, problem maybe a little more. At least these suggestions won't cost you money to check them out it sucks to keep throwing parts at and not get anywhere I have been there and done that. I will always start with the cost free checks first and if I can't figure it out then I will take it to my trusty mechanic he is the only one that I will let touch my truck when I'm home. Like someone else, said the mechanic that suggested you need more HP and to put a tune in it is a mechanic I wouldn't go back too these trucks are more than capable to pull heavy loads without a chip. You even said before this happened you had no, problems pulling your loaded trailer before and you didn't have a tune in it. Adding a tune for more power is nice but, it is not the answer to your problem.
That’s wat I was thinking that the turbo might not be any good but the check it n said it was running just fine even wen I was going uphill wen he had computer hook up he told me that it was working perfect
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #33 ·
That’s wat I was thinking that the turbo might not be any good but the check it n said it was running just fine even wen I was going uphill wen he had computer hook up he told me that it was working perfect
I did notice one thing while going up hill it’s like the radiator fan start to blowing really hard dnt knw if that’s sun n another thing I dnt never see the truck smoke just in the morning wen I first start it n the smoke be white not black
 

·
Registered
Joined
·
667 Posts
Did they actually, pull the intake tube off going to the turbo and inspect the impeller for wear or are they just saying it's good because, it is making boost. If they didn't pull the tube and look at the impeller that is something that you need to check easy to do.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #37 ·
Did they actually, pull the intake tube off going to the turbo and inspect the impeller for wear or are they just saying it's good because, it is making boost. If they didn't pull the tube and look at the impeller that is something that you need to check easy to do.
They had to cuz I see the small rubber piece is new
 

·
Registered
Joined
·
667 Posts
Well, **** I'm out of suggestions hopefully, others will chime in with their thoughts. Good luck! and keep us posted. If you figure it out let us know.
 

·
Registered
Joined
·
667 Posts
Silly question when was the last time you changed your fuel filter and air filter?
 
21 - 40 of 50 Posts
Top