The Diesel Stop banner

1 - 20 of 28 Posts

·
Registered
Joined
·
298 Posts
Discussion Starter · #1 ·
A couple of weeks ago I was towing a 13Klb trailer on the highway up a pretty good mountain. I couldn't get it to go over 50mph. I noticed occasionally the oil pressure gauge would "drop" really fast to zero and then go back to normal. I pulled the codes with my AE and got the P1247--turbo boost pressure low. I don't notice any problems driving around (no load). Any ideas where I should start looking?
 

·
Registered
Joined
·
16 Posts
I've come to the conclusion on anything like this, it's best to start with a compression test. Even if you have to pay for it, you might as well make sure you have a solid base to start.
 

·
Registered
Joined
·
634 Posts
1st thing that I would try since, it won't cost anything is remove your exhaust back pressure sensor and clean it and the copper tube or stainless tube whichever yours happens to have. If yours has the copper tube check for any pinholes or green corrosion on it if it has a little green corrosion on it if you were to scrape it off you will probably find a pinhole in it like I did mine if that was the case just replace it the new replacements are stainless tubing about $80. Try to clean the inside of the tubing the best you can because, carbon builds up inside of it which crystalizes and restricts the tubing me I just replaced mine because, of the corrosion and pinhole I found on mine. The best way to clean the sensor is pull it off turn it upside down and use a small eyeglass flat blade screwdriver stick it inside the hole and just gently scrape it and the tap it on a white paper towel and you will see the black carbon that comes out and then I spray brake kleen or carb. cleaner and repeat with the screwdriver and tap it out onto the paper towel your not going to hurt the sensor. If yours has never been cleaned out I would repeat 4-5 times then put it back in and see if your boost comes back. You could also, have a leak at one of your boot clamps or pinhole and also, your truck has a wastegate solenoid which mine does not but, you have small plastic tubing going to it which could have a leak someone may chime in that knows more about your wastegate solenoid better than I do. But, the last time I was losing power pulling up grades with a load it was the EBP sensor no, need to replace it they very rarely go bad they just get dirty I had over 950,000 mi on my original sensor. I would try cleaning the sensor and tubing 1st and then go from there. Good Luck! and keep us updated.
 

·
Super Moderator
Joined
·
26,385 Posts
I noticed occasionally the oil pressure gauge would "drop" really fast to zero and then go back to normal.
The oil pressure gauge works off a switch that closes at about 7 psi.
First thing I would do is check your oil level (that's free, well unless you have to add oil ;) ). Low oil can cause air entrainment in the HP oil system, causing problems with injector operation. It would be more evident climbing a hill than on level ground.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #5 ·
Thanks. I'll try cleaning the EBPV. The boots all check out good--I replaced them a few years ago. The oil was just changed and full before I started towing up the mountain so I can eliminate that.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #6 ·
I did some more research and determined I don't really need the EBPV. I think I'll do the delete with a new pedestal. Any ideas on the best one to buy or where to steer away from?
 

·
Registered
Joined
·
1,722 Posts
RockAuto has one for $90 that I just installed. Good looking unit.
And here is a coupon;
Code: 162906704148844000
 

·
Premium Member
Joined
·
4,327 Posts
EBPV (valve) is a different animal from the EBPS (sensor).
The issue you describe is notan issue with the EBPV.

Also, it takes 2 seconds to check your oil level.
Relying on what the level was a week ago is a bad habit.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #9 ·
I checked my oil before the trip, after the trip and every time I fill up with the diesel. My habits are good.
 

·
Premium Member
Joined
·
4,327 Posts
I checked my oil before the trip, after the trip and every time I fill up with the diesel. My habits are good.
Thats good to hear. I was worried when you assumed your oil level was good without mentioning you checked it after the problem.

The oil was just changed and full before I started towing up the mountain so I can eliminate that.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #11 ·
I cleaned that sensor tube and sensor a couple years ago. I'll try it again--it's not that hard to do.
 

·
Premium Member
Joined
·
9,489 Posts
You can always just disable the back pressure valve by unplugging it and wiring it into the open position.

Do you happen to have a boost gauge to watch the boost pressure?
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #13 ·
I have Auto Engenuity. I'm pretty sure it monitors boost.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #14 ·
It doesn't look like it does. I did a KOER test and it threw a P0476--exhaust back pressure control valve malfunction.
 

·
Premium Member
Joined
·
9,489 Posts
Hook up the AE and go for a drive and see what your boost pressures are as you are driving up a hill, it could be a bad MAP sensor.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #16 ·
I didn't see a way to read boost pressures.
 

·
Super Moderator
Joined
·
26,385 Posts
What you want to look for in AE is MAP - Manifold Absolute Pressure. Should be a couple of parameters you can see, PSIA or possibly MAP voltage.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #18 ·
Excellent. Thanks.
 
  • Like
Reactions: ArcticDriver

·
Registered
Joined
·
298 Posts
Discussion Starter · #19 ·
This weekend I hooked up AE and went for a drive. The MAP pressure read about 13 most of the time. When I went up a hill and got on the accelerator a bit the MAP would climb to 23 and then just drop off to 12.
 

·
Registered
Joined
·
298 Posts
Discussion Starter · #20 ·
Any ideas what is going on?
 
1 - 20 of 28 Posts
Top