The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Hi everyone

I think the batteries on my dad's truck were on the way out so I went to replace them. When I hook the negative cable up to terminal, the truck starts to crank? Could this be due to a bad ignition switch, or starter or starter solenoid? It seemed to be working fine previously so not really sure what the issue is...

Thanks
Fred
 

·
Registered
Joined
·
266 Posts
I've only seen that happen if there's a remote start installed. Have someone sit in the truck with there foot on the brake while you hook up the cables. Pushing the brake pedal deactivates the remote start.
 

·
Registered
Joined
·
3 Posts
Most likely a bad solenoid as the starter staying engaged.This could of been part of the battery issue as the starter may have stayed engaged once the engine started.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #4 ·
I've only seen that happen if there's a remote start installed. Have someone sit in the truck with there foot on the brake while you hook up the cables. Pushing the brake pedal deactivates the remote start.
No remote start installed

Most likely a bad solenoid as the starter staying engaged.This could of been part of the battery issue as the starter may have stayed engaged once the engine started.
is there a way to replace just the solenoid or do I need to replace the entire starter?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
Ended up replacing the starter since the local auto parts didn't have just the solenoid. Works like a charm now! Must have been the solenoid that went bad.
 
1 - 5 of 5 Posts
Top