The Diesel Stop banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys hoping someone has some insight on this. I'm hoping it's just one of the solenoids in the transmission.

Serviced the transmission about 5000 miles ago (new fluid and filter). I have a Spartan tuner and pull my camper (about 8,000lbs) with the truck in the 210 tow tune early lock. Two days after pulling the camper about 150 miles and driving normal I got into the truck and now it seems to go into neutral before going into 4th or it will stumble a little before going into 4th, and if I don't let off it revs and slams into 4th pretty hard. All other gears shift fine and no sign of it slipping even when pushed harder. Tried reloading the tune with no change. If I manually select on the column 1-2-3 then to D it will still do the same thing between 3rd and Drive

(When I serviced the transmission the fluid was a little dirty but pretty minimum amount of material on the magnet)

Details of truck:
2009 F-350 4x4 Lariat Crew Cab, automatic
- Spartan tuner (210 early lock for everyday driving, 210 tow tune early lock when hauling)
- AFE turbo back exhaust (no muffler, no DPF)
- Sinister EGR delete with intake pipe
- AFE intake
- Turbosmart BOV
 

·
Super Moderator
Joined
·
12,019 Posts
What fluid did you use when you serviced it?
 

·
Super Moderator
Joined
·
12,019 Posts
Brand doesn't matter. You used the right fluid.

The first thing I'd try is to disconnect the batteries. The adaptive software occasionally learns itself into a hole that it can't learn it's way out of. The first few shifts after doing this will probably be worse, but they should start to improve very quickly.

If that doesn't solve the problem I'd suspect a failing direct clutch solenoid.
 
1 - 4 of 4 Posts
Top