The Diesel Stop banner
1 - 3 of 3 Posts

·
Registered
Joined
·
577 Posts
Discussion Starter · #1 · (Edited)
I left work on friday and my truck kinda stumbled and the SES light came on...odd. Once i got on the road and it warmed a little, i hit 40 MPH and it started vibrating bad. Figured the UVCH, called ford and they ordered the clip/shims and I got them Saturday afternoon and put them in that evening. The passenger side was fine but the drivers side was loose about 1/8". Took it apart and checked the pins which were fine, put the shim in and put it all back together, and the harness's looked fine.

As luck would have it, it was a complete waste of time, SES still on, truck idle's rough and runs like crap once it warms up and hitting 40 and above, it doesn't run the best under 40 but way worse above it. When the light goes out and runs fine and pulls good, when it comes back on it runs bad again.

Im going to call some local shops tomorrow to see if they have a "real" scanner to check the codes, if not off to Ford.

Do you guys have any ideas what would be a next looking place?

Thanks
 

·
Premium Member
Joined
·
2,197 Posts
I'll say start by the code and yes make sure the scanner is power stroke capable


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
4 Posts
I have a 99.5 f250 that is doing the exact same thing. I changed the icp sensor and pigtail both was full of oil, now it will run good a day or two and start again. The exact same thing as before changing the icp. Need good diesel shop around Hickory NC anybody know one. Thanks.
 
1 - 3 of 3 Posts
Top