The Diesel Stop banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I bought a replacement S&B filter for an S&B intake that I, unfortunately, had installed a couple years ago. The original filter fit really well but was very worn looking so I wanted a new one. The new one never fit very well and recently popped off completely allowing all kinds of leaves dirt bugs etc into my new turbo. I have communicated with them at length and they even sent me a new filter and I sent them the one that kept falling off but it also falls off. My question is what can I do to help my engine recover from this issue aside from taking it apart
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I have an 02 7.3 with 272K modified and again seeking advice as to how to proceed from here with the truck. I haven't used it much since this happened. I changed the oil and stuck my hand as far as I could pulling out garbage that got sucked into the big Garrett turbo. After that, I guess it goes to the Mishimoto intercooler and not sure after that.
 

·
Premium Member
Joined
·
3,615 Posts
Are the fins on your compressor wheel damaged? You will need to pull of the intake tube from the turbo for a good look.

Once the Charged Air leaves the intercooler, it goes into the Intake Plenums and into the cylinders. After that it is burned up and expelled through the turbine side of the turbo to the exhaust. The majority of any damage will be at the compressor wheel. So it it looks good, you are as far as you can be. You could perform a compression test to see how the engine is performing, but unless it was a lot pf debris, you probably won't be able to tell.
 

·
Registered
Joined
·
4,611 Posts
The intercooler will act like a filter for most of the bigger stuff. Pull it and backlash with water to clean it and the pipes then blow dry and put it back in. Check the compressor wheel as suggested if it is fine I would just keep driving.
DENNY
 

·
Premium Member
Joined
·
3,615 Posts
Why do you not recommend S&B? From the other forum you posted on you ordered the wrong filter for your truck. I believe that is the issue you are having.
 
1 - 6 of 6 Posts
Top