The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 · (Edited)
Hello All:

While driving on a 1000 mile trip, about 200 miles into it, the dash gages went off and did a full sweep, the Sync went black and came back on stating it was doing a system maintenance update.
Kinda spooky while you're driving, I was hoping the engine wasn't going to shut down too. Everything came back up, and we continued on without any further issues.

Anyone ever experience this? Why would it update while you're driving?
I did run the codes, scan indicated that various modules lost communication and set some temporary U0xxxx codes. Huh?

Thanks for clues!
 

·
Registered
Joined
·
2,501 Posts

·
Registered
Joined
·
83 Posts
I went through a spell where that was happening on mine....come to find out, the cause was a grey connector near the parking brake that had a loose connection. The routing of the cable allowed it to shake loose through repeated use of the parking brake. The dealer re-connected and secured the wire bundle away from the assembly and no problems since.

Cale
 

·
Registered
Joined
·
1,520 Posts
MFT has nothing to do with your instrument panel. Mft can reboot "performing scheduled maintenance" and it will not kill your instrument cluster. The maintenance message is a polite way something went wrong with MFT and is just doing a reboot (it does happen).

If your instrument cluster went dead to then I lean towards what was said above, a loose connection.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #5 ·
I found the grey connector, but it was tight and the clips locked in. Disconnected/reconnected, we'll wait and see if this was it. Kinda doubting it though. Looks like a network type wiring. had a white tag on it.

Thanks for the leads.
 
1 - 5 of 5 Posts
Top