The Diesel Stop banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey all, been a while since ive posted. Figured id update and to some extent inquire. My last post was about my 01 7.3 f250 and its mystery oil leak. Well, a lot has happened since but to catch up turned out to be pedestal and ebpv leak ( yes both) after resealing 3 times and purchasing the ebpv delete variant of the pedestal. I thought i had downright lost my mind when i could still only make it 15 miles before needing to pull over and refill nearly my entire oil capacity. ( deisel oil may be cheaper than gasser but at that extent i dont think anyone could sustain that kind of consumption) turns out i removed the original hpop fittings inappropriately when i upgraded to the flared fittings and stripped the hpop ( still fighting that one gonna have to buy a new pump it appears) all the while my truck seemed to be weaker and weaker on power. Even after halfass sealing the fitting by boring tapping and using a makeshift replacement fitting that a friend welded for me. I chalked it up to either injector failure or impropper oil pressure because of the leak.
I was at oreillys yesterday buying ( you guessed it ) oil and noticed lucas fuel injector cleaner was on sale and scoffing at the idea that it would have any effect grabbed a bottle anyway. Poored it in the tank before departing and went about my way with my struggling 7.3...half way home i was forced to downshift by another driver being an absolute plebb in front of me and the truck just dies. I fought like hell to get this thing going again but finally she rolls over and what the hell happened?! I no more than hit third gear and this rig says oh you wanted fast? And throws me back in my seat like i was driving a sports car!!!
Ever since shes been a beast yet again...so im stumped. Not complaining at all.. but what caused the power loss? Running low on oil allowing heat to for lack of a better word gum the oil in the injectors?
Moreso should i consider new injectors after my hpop replacement? Just the o rings? Now with her newfound youthful exuberance i notice on heavy acceleration i catch almost a carbon smell im thinking ( or maybe more hoping) its the cleaner putting in work on the injectors but unsure. she rolls coal again and last 0-60 was 4 seconds flat. I am running a bulydog gt tuner moniter but this is all just preformance mode kinda scared to touch on extreme mode for fear of my hpops condition. Still fighting a slight oil leak but nothing compared to how bad it was at its worst
In summary i think a lot of people ( myself included) always assume the worst or try to tackle issues much more complicated than necessary. Enjoy the little things, grab some fuel injector cleaner. And thanks to the seasoned folks on this forum for their ongoing patience and advice to newjacks like me who would be lost without them.
 

·
Premium Member
Joined
·
1,395 Posts
I don't believe injector cleaner poured into the fuel does anything for the injectors, I call snake oil on that stuff. Maybe the injector cleaner ate some of the crud off your in tank screens. Have you ever dropped the tank to check them, or done the Hutch mod? On a side note 0-60 in 4 seconds with a 7.3 truck?? I had no idea that was even remotely possible with canned tunes.
 

·
Super Moderator
Joined
·
25,753 Posts
On a side note 0-60 in 4 seconds with a 7.3 truck?? I had no idea that was even remotely possible with canned tunes.
Yeah, that's a bit of a fisherman's tale. An online calculator for a 350 BHP engine, 7400lb 4WD vehicle comes up with just under 8 seconds. The 350 HP might be a bit optimistic as well, unless you're highly modified. I couldn't find my dragstrip timeslips, but I ran mid 16's at about 86 mph 1/4 mile trap speed. I think the timeslips had a 0-60 estimate.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Time was
I don't believe injector cleaner poured into the fuel does anything for the injectors, I call snake oil on that stuff. Maybe the injector cleaner ate some of the crud off your in tank screens. Have you ever dropped the tank to check them, or done the Hutch mod? On a side note 0-60 in 4 seconds with a 7.3 truck?? I had no idea that was even remotely possible with canned tunes.
The timing is based off of my bullydog running performance testing on a backroad near where I live I can take pics if you like. I was stunned as well, I haven't personally done a hutch or harpoon and the previous owner seemed mighty neglectful so I doubt seriously that he had had performance injectors added, frankly I was under the impression that the only thing he had done to the truck was added 20 inch rims without lifting the truck properly. I can run the test again however, now I'm facing a new issue it seems that once the truck has been ran for a good while ( 20-30 minutes of drive time) in fifth gear she craps out so to speak. To expand, if I press the pedal too far leading up to fifth or hit fifth gear at all it feels like I'm hitting the breaks and she spits and sputters. To fix this I have to pull off and either let her idle or shut her down entirely then once she cools down its like there was never an issue for about 15 minutes then boom right back to acting up .....got me scratching my head yet again. Gonna have a bald spot at this rate
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5 (Edited by Moderator)
Yeah, that's a bit of a fisherman's tale. An online calculator for a 350 BHP engine, 7400lb 4WD vehicle comes up with just under 8 seconds. The 350 HP might be a bit optimistic as well, unless you're highly modified. I couldn't find my dragstrip timeslips, but I ran mid 16's at about 86 mph 1/4 mile trap speed. I think the timeslips had a 0-60 estimate.
Running a custom Dana 60 rear diff with a zf6 trans rwd only, this truck gits brotha lol
I'm not one for tall tales I know how it sounds, that's one of the reasons I shared. Just odd to me this truck went from super powered to underpowered in such a short succession. Any advice would be greatly appreciated afterward I'll gladly post times and evidence off of my monitor which is where I pulled the original time
 

·
Registered
Joined
·
1,741 Posts
Bull. You would need almost exactly 893 hp to achieve 0-60 in 4 seconds flat.
That will not happen with a junky bully dog tuner.
Try a phone app like torque to record your 0-60.

Sent from my SM-N960U using Tapatalk
 

·
Premium Member
Joined
·
1,395 Posts
I would bet you are having a fuel problem. Time to drop the tank and do the Hutch mod. A fuel pressure gauge would be ideal right now, you can temporarily rig one up off the fuel bowl drain and run it over to the windshield to see while driving.
 

Attachments

1 - 7 of 7 Posts
Top