The Diesel Stop banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi: I have a tow haul problem with my 2008 F350 6.4L. It will not go into tow haul unless I tilt steering wheel up all the way and than slam it down and than it will engage. Than when I want to take it out, I have to shut off truck. Does any one have a wiring diagram and info on how to get at the wiring. Do I have to disarm Air Bag and pull Steering wheel? It has been like this for a year or more and no warranty on that part they tell me. Any help should help, [email protected] :ford::read:
Thanks Haakeye
 

·
Super Moderator
Joined
·
11,629 Posts
You don't have to disarm the airbag or remove the wheel. The screws that hold the plastic steering column are located on the underside of the column. Remove the cover and you'll see the damaged wires where they enter the shift handle.
Either repair the wires or replace the shift handle. They are around $65 at a dealer.
 

·
Registered
Joined
·
3,532 Posts
wiring diagrams can be obtained from Helm,inc on their website

subscription is about $20 per month
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Thanks

Thanks Mark I tried to figure out wiring and switch and than bought a new lever and switch. works well now. I than took the old one apart even further and found the broken wire, I repaired that wire and now I have a spare unit.
Thanks again.:yesnod::jester:
 

·
Registered
Joined
·
1 Posts
Tow/Haul Problem

Hey Guys, I have the exact same problem. I'm trying to be fairly careful with removing the plastic covers. I don't want to damage them, but they seem to be really difficult to pull apart. Any suggestions???
Mark
(08' F-350 6.4L Auto)
 

·
Registered
Joined
·
1 Posts
tow haul problem

hello I have a 08 f250 ,it has gotten to the point where it will only go into tow haul if im in park .it used to engage while in drive and then only in neutral and now just park ,would this be the same wiring problem ,thanks
 

·
Registered
Joined
·
1 Posts
Hi I have a 2006 f250 6.0 L 4x4 with the tow haul engaging on its own and causing the transmission gears to slam in I have changed the TTF sensor , the transmission range sensor , Ive checked the wire harness to the transmission and it looks good has anyone had this issue
 

·
Super Moderator
Joined
·
11,629 Posts
Why did you change those unrelated sensors? They have nothing to do with tow/haul. Neither does the wiring harness to the transmission.

You should read this thread. The answer to what's wrong with yours is right there.
 
1 - 10 of 10 Posts
Top