The Diesel Stop banner
1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Been a while since I been on here. Recently had to take my truck to have the trans rebuilt and that is where the the problems got worse. Shop said the torque converter locked up and blew the front pump. So he also said it got really hot. In fact he said it was hot enough to melt the filter and shift solenoid. Long story short after a complete rebuild he told me the TCM was bad. Found a rebuilt one and now he tells me that it still isn't sending a signal to trans. They are hard to find and aren't cheap. Is there something else that could be the problem? I have already put 2 different ones in and have the same issue.
 

·
Super Moderator
Joined
·
12,097 Posts
It's really hard to say from here. It could be the power relay that powers the PCM, or it could be the wiring between the PCM and the transmission.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
When the trans went out and was rebuilt he said the TCM was bad. I sent it in for repair. They told me it was impossible. The processor was fried. So I purchased a remanufactured one. Now the trans shop says it is still not getting signal to trans. I am having a hard time believing that it is the TCM. They test them before they sell them.I am trying to figure out if there is an upgrade for the original. I will see about maybe a wiring issue. Thank you for your help. Any advice is appreciated.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Just talked to the trans shop. They said the remanufactured TCM isn't sending a signal. All of the other solenoids are working except the one for the converter. I ordered another one. If that doesn't fix it I don't know what is next. The chance that 3 of them are bad is almost impossible. I will keep you posted.
 
1 - 4 of 4 Posts
Top