The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hey guys i have a 96 7.3 with 200k miles and around 30k miles on a rebuilt e4od transmission. Ever since i had the transmission rebuilt i have had problems. Its been returned to the shop about 4-5 times and now the guy is out of business for obvious reasons. On most mornings on the first stop my trucks makes, after having been driven enough to shift through all gears, its as if the torque converter doesnt disengage and if i stop the truck it will lug out and die. I can stop it by shifting down to first or nuetral and it wont lug out but if i throw it into drive to take off it will die and after i restart it and put in drive it will lug out. If i restart out in first and then shift up in gears as i go it will shift hard but then after a few miles it will be just fine. the next stop i make it will work just fine and if i drive it throughout the day i have no problems. Thanks for any advice in advance
 

·
Super Moderator
Joined
·
12,015 Posts
Your problem is low pressure. It could be from low fluid level, a bad internal filter, internal leaks, or a bad pump.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Can I get to the filter and pumps without pulling the tranny. I've never worked on an e4od befor. Fluid level has been fine
 

·
Premium Member
Joined
·
15,115 Posts
The filter is accessible by pulling the pan. To get to the pump, the transmission has to come out.
 

·
Registered
Joined
·
123 Posts
If you pull the pump, make sure you have the transmission vertical. I made the mistake of not doing that, and when I installed the new pump, I bent all the clutch packs for 3rd and 4th gears.
 
1 - 5 of 5 Posts
Top