The Diesel Stop banner

21 - 28 of 28 Posts

·
Registered
Joined
·
296 Posts
I'd disconnect one of the batteries, then use a multimeter to see what the amperage draw is on the other battery with the key and all loads off. This info should be very useful.
 

·
Registered
Joined
·
2,165 Posts

·
Registered
1995 f-250 2wd 5spd
Joined
·
37 Posts
Discussion Starter · #23 ·
Ok I will. I went to start the truck today and it started right up. Drove about an hour away and the truck won’t start. When the light switch is activated it shuts off my odometer and RPM But the truck runs fine. I need to get this looked at ASAP
 

·
Registered
Joined
·
23 Posts
I'd put a charger on the batteries and get a full charge on them and then start doing some testing.

It would have to be one large draw to kill both batteries

Sent from my SM-J737V using Tapatalk
I had a 1999 240, that did really crazy electrical stuff, head lights would make the wiper blade sprayer shoot water, one side of the truck the lights were dim, after searching for days !!, I gave up, took it to ford, took then 4 hours to discover only a bad ground wire, on the frame, near the right battery
 

·
Premium Member
Joined
·
9,487 Posts
I had a 1999 240, that did really crazy electrical stuff, head lights would make the wiper blade sprayer shoot water, one side of the truck the lights were dim, after searching for days !!, I gave up, took it to ford, took then 4 hours to discover only a bad ground wire, on the frame, near the right battery
Back in the days when everyone had a CB radio in their truck I came upon a problem in my truck. Whenever I would key the mic to talk to someone the windshield wipers would cycle. This was traced back to a bad ground.
 

·
Registered
1995 f-250 2wd 5spd
Joined
·
37 Posts
Discussion Starter · #26 ·
SOLVED! Alternator had a cracked eye terminal under the boot! It just came off upon further Inspection and I replaced that and now it’s charging again!

One thing I noticed now is upon first cold startup it surges upon idle for about 20 seconds and then goes away. Anything to be concerned about!?

im so glad thank you everyone for helping me out with this!
 

·
Registered
Joined
·
2,165 Posts
My truck's startup surge was caused by a bad MLPS indicating R instead of P.

(click this text)
 
  • Like
Reactions: combatvolcano

·
Registered
Joined
·
4,947 Posts
Is this a new problem? If you can't find any other cause try changing oil brand/weight. The 7.3 can be oil sensitive.
DENNY
 
21 - 28 of 28 Posts
Top