The Diesel Stop banner
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I'm new to the ford world and hope it get's better
I have a 2005 f250 6.0 I was going down the road and it just shut off never to start again :(
I have both new filters fuel good flow at the top filter I cracked the banjo bolts and it sprayed fuel about 6 ft on both heads it has a new icp screen new batteries and now a new starter. don't shoot me but I was despite and when I spay starter fluid in it its starts and I can keep it running on ether while running it builds oil pressure
I only have a P2280 code & P0148
108,000 miles
any help would be greatly appreciated, Thanks
 

·
Registered
Joined
·
5,430 Posts
1. Don't use ether anymore
2. Read the no-start sticky thread
3. Get an electronic gauge system to read engine parameters (scangaugeII or android's TorquePro app).

Once you get the gauge system, then you need to post the cranking ICP readings (as well as the FICM sync and the cam/crank sync). Also helpful would be the 3 FICM voltage readings when cranking (MPower, LPower and VPower).
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Went through the sticky
Builds oil pressure on the dash gauge about ½ way in about 12 seconds
No chaffing found but ipr wire looked a little melted hand separated and ohm tested good
Disconnected the icp
Oil still looks good 436 miles since oil change
Fuel filters replaced a last month, pull upper koeo fuel flowed over the top
Fuel pressure is about 63psi until the pump cuts off then it drops
Ficm is 48.7 koeo & 48.6 turning over

So I have verified I have good lpo, fuel pressure getting in to the rail, and air so I either have a high oil pressure issue or a injector issue??
Just purchased a blue tooth adapter for the torque app so hopefully I can get more data soon.
 

·
Registered
Joined
·
5,430 Posts
Sounds like it is a high pressure oil issue. The ICP and IPR data, along with the Sync values, should narrow it down.

Is it getting 150 rpm or higher when cranking?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
I got some ScanGauge numbers :D

KOEO----------CRANKING
IPR 14.8 --------84
ICP 0 -----------26
SYS 0 -----------1
FMP 48.5-------48.5


2005 no start
 

·
Registered
Joined
·
5,430 Posts
Sounds like you have an issue with the high pressure oil pressure. Could be a leak (dummy plugs are very common leak point), a bad STC fitting (common failure point if the upgraded fiitting has not been installed), or possibly (not as likely though IMO) a bad IPR valve.

Do an air pressure leak test of the HPO system.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
has new 1 piece with nylon stand pipes and dummy plugs and updated stc, I had the engine tore down did studs, hg, stc, stand pipes, dummy plugs, blue spring, oem oil cooler, coolant filter,egr delete kit, front mail seal and insert, water pump, heads completely reworked, and every oring and gasket from the heads up, turbo feed, turbo drain, tore down and cleaned turbo

the only thing I did not do was replace the ipr but I did change the screen and oring and left the HPOP but oring and sealed it and put in updated stc because it looked good
I literally did every thing that was recommended to this truck, over the last 500 miles ago I was confident this truck would last me and my sons a life time I have went as far as new body bushings, traction bar bushings, shocks bilstein 5100 if it showed wear it was replaces this is the only truck I have ever put so much time and love in :( but with you guy's help me and the boys will figure it out and have good memories when it fires off SOON :D I will pull the IPR tonight and hope I find something screwed up
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
FIXED IT

Found IPR screen stopped up with a small hole in it looked into the valve and found the missing screen piece cleaned the screen and put it back in and IT STARTED YEAAAA so ill be off to get a new on in the morning but my biggest concern is what is it and why did it happen I just put that screen on it when I had it all tore down, did I let dirt and trash in when I did the stc ?? or maybe from the head work, Thanks for the help guys
 

Attachments

1 - 9 of 9 Posts
Top