The Diesel Stop banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Every day that I start the truck, it takes a lot to start it...

I turn it to "on", wait for the "clicking" to stop, then turn the key to "Start". It immediately starts turning over, but it doesn't catch (acts like no spark or no fuel). Eventually, It starts to catch for a second or less then not... Eventually (except today), it does start... The whole process generates a LOT of white smoke...

When it has been running earlier that day, it starts with no delay when I turn the key to "Start".

What could be wrong (I'm not ruling out user error)
 

·
Registered
Joined
·
9 Posts
If all your glow plugs were functioning properly there likely wouldn't be any clicking. I would start by checking for bad glow plugs. If you have smoke, you have fuel.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17,604 Posts
When you turn the key to "on" does the Wait to start light come on? If it doesn't and the controller starts clicking immediately, you have glow plug issues.

On a cold start, the controller should energize the glow plugs for 12-15 seconds and the WTS light should be on for the same period of time. The clicking is the controller cycling the gp's.

If you change the glow plugs DO NOT use Autolite plugs. Motorcraft ZD9 is what you want. I have a set of DieselRX that have been good for several years, others haven't had the same experiences.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
When you turn the key to "on" does the Wait to start light come on? If it doesn't and the controller starts clicking immediately, you have glow plug issues.
When I turn the key to "on" the WTS light turns on for about a second. It seems to turn off as soon as the "clicking" starts.
 

·
Registered
Joined
·
17,604 Posts
With your white smoke and the WTS light not staying on, I would change glow plugs.
 
1 - 6 of 6 Posts
Top