The Diesel Stop banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2003 F350 Super Duty Lariat and my turn signals, hazards and brake lights keep turning off. The console lights as well as the exterior lights. I checked the fuse and it was burnt, so I put in a new one and it all worked, I pulled out of my stall, reversed, pulled back out and turned onto the road and it burnt out again. I replaced the fuse, once again, and it did the same thing. Does anyone know if it's wiring, the switch itself or the hazards? I don't want to take it in, because that would be a waste of money if it's a simple fix, I just need a general area to start.
 

·
Registered
Joined
·
527 Posts
My first guess would be a short in your trailer harness connector in the back of the truck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
This could be the cause, even if I don't use a trailer?
 

·
Registered
Joined
·
527 Posts
Wires could be damaged. I had one on my f150 that got hot and shorted out. Also had one the dog chewed up. You have a shorted wire somewhere. I would start there because its exposed.
 

·
Registered
Joined
·
1,876 Posts
This could be the cause, even if I don't use a trailer?
Yup. In a sense "use it or lose it."
If you're using it, you will see the condition of it frequently. Not using it, you will never inspect it.


Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
1,290 Posts
The fuse your changing is it F2.27?

From the wiring diagram I wouldn't assume the trailer wiring.
 

·
Premium Member
Joined
·
9,586 Posts
It was either on these forums or somewhere else but a person had almost the same problem and traced it back to a socket on the lights being bad.
 

·
Registered
Joined
·
2,446 Posts
I'm pretty sure all of the 99+ trucks have separate isolated circuits for the TT wiring. So no point looking there IF that's the case. If turning on either signal fries the fuse, I don't think it could be a light socket, if only one or the other signal blows it, then yes, my bet is on a lights socket issue or harness problem to the socket.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
I have no idea, I just know it's the 20 amp fuse in the #18 slot
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
It's weird, when I'm in park, hazards work, blinkers work, brake light works but once I drive or turn, it seems that there's something in the steering column perhaps, that is making it burn.
 
1 - 11 of 11 Posts
Top