The Diesel Stop banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I've read several threads on this topic, and not really wanting to create a new one, but very few responses on them.

2000 Excursion/F250 issue...

My turn signals will occasionally work, hazards work 100%, brake lights work...
Both relays are now EP27's under the dash as of last Fall
Multifunction switch is replaced...
Fuses are good...

Stabbing at a guess of wiring, but seeing column, fuse locations, sockets...
What wisdom do we have on this in 2022?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
MFS replaced after they quit working... twice with new replacement MFS.
The signals do not flash, click or anything... lever clicks and locks in, but nothing happens.
Yesterday they worked on the way home... and then di nothing this morning on my way to work.
Bulbs in signals are stock replacements... worked fine prior to quitting.... been replaced as testing for bad components...
Both relays replaced under dash...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I can't help you without details. Are you saying you replaced the MFS without any diagnosis? The original MFS didn't fail any test? Do you still have it? And the new ones (WHAT BRAND/PN/SOURCE???) didn't pass any test? And you did that 2x? Do the turn lights light up when the lever is locked, or not? This page shows how to test the MFS:

(click this text)
Not to frustrate you... but the facts are as follows..
Diagnosis from the gravel driveway started with relay replacement.
Signals gradually failed and the research said to start with Relays.

Existing MFS was the original factory from 1999 build, replacement was sourced from Rockauto.... in 2020.
Remote possibility it has not been cleared off the deck... yet.
• MFS testing, had not seen a spec sheet even detailing it until this...
And no... they do not light at all...
[Hence: "The signals do not flash, click or anything... lever clicks and locks in, but nothing happens. " detailed as I can get without video addition on non-existent Youtube account]

What other details can I provide???

As for the issue... now a further development which gives me a clue as to the issue, but no idea where to track it.
Braking.... anytime, lights the driver side signal solidly with brake lights.
My XJ had a bit of issue in the rear quarter with the lights doing this and it was short in the rear quarter.
Have inspected anything in the rear taillights, nothing there to create this wrinkle.
The wiring has to meet somewhere... have not figured where yet.
Again, best details I have without video feed, which I don't have outlet for if I took it.

Thx for taking a moment to answer... seems a lost art unless one is on fb asking • lift • tire size • headlight replacement • how to improve fuel economy • or should I insert action to MY vehicle
 
1 - 3 of 3 Posts
Top