The Diesel Stop banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
hey guys im new to this site. ive used your forums to answer some of my problems in the past, so i was hoping you can help me out with this one.

i have a 92 f350 dually. 7.3 non-turbo, auto 2wd

i just recently installed a new alternator and ever since then when i start my truck my wif and wts lights glow at about 50% brightness and my amp/volt gauge stays high. (at the "a" or "l")

the truck starts fine as usual in warm days and really cold days (35-70 degress)

any help would be great, thanks.
 

·
Registered
Joined
·
326 Posts
double check the wire connections at the alt and the fuel filter you might have accidentily bumped it and it is making a ground and the WIF light is turning on because of that. also the little piece of plastic beween the bulbs could be missing causing a false wait to start light typically it only is lit when the glowplug controller is working, I assume that it is brightly lit when you go to start the truck.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
yes the wts light is bright and crisp before starting. afterwards it is dim but on, same with the wif light. i did check the wire on the filter right away... it is attached and tight.

i forgot to mention that about half the time when the engine is warm the lights dont come on for the first few minutes. ill look over occasionally and notice them on while driving.
 

·
Registered
Joined
·
6,680 Posts
the lights ground to activate. disconnect them when they light and see if they still light. if they do you have a short to ground.
 

·
Registered
Joined
·
326 Posts
yeah sounds like you might have a ground issue in your wiring harness.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
yeah it must be an issue with a grounded wire. ive tried everything else. by any chance do you guys happen to know what color wires and which harness they are in. I believe there are two harnesses that go thru the firewall.

on a side note... do uploaded pictures have to get approved on here. i uploaded some of my truck but dont see them in the gallery? thanks
 

·
Registered
Joined
·
6,680 Posts
1 - 8 of 8 Posts
Top