The Diesel Stop banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok new here seams like a good place to get reliable info,here is my MASSIVE problem I have a 2001 7.3 with 160k,with an edge evolution programmer.I can start it right up no problem what so ever.then ill pull out drive a mile or 2 and when it gets to running temp til start loosing all pull up hill then eventually all together with a lot of shaking and it sounds like it's bangin on 2 cylinders,,,,So far I've dropped the tank cleaned it replaced the broke pick up screen,New fuel pump,filter,cps,icp,oil,oil filter,breather,heating element,checked my uhvc,injectors,and still same damn thing happens..I haven't replaced coolent r checked that area yet but I will do anything at this point,,this truck is my baby lol and I refuse to quit,,can any1 plz give me some solid things you May think is wrong and how to check them....thank u ahead for replies hope ta stay around
 

·
Registered
Joined
·
2,846 Posts
first off pull the edge out and put it back to stock.

did you get a new oem cps or aftermarket? go with oem if you went aftermarket.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
The new oem but I'd like to get the 1 from international,I also got a fairly new water pump and alt.cleaned my fuel bowl and got rid of spring for filter,I've had a gut filling about the edge lately,any other ideal though I'm all ears anybody
 

·
Premium Member
Joined
·
3,754 Posts
1 - 4 of 4 Posts
Top