The Diesel Stop banner

341 - 353 of 353 Posts

·
Registered
Joined
·
106 Posts
These days, of Better Living Through Chemistry, I almost always use a thread locker when assembling things.
 

·
Registered
Joined
·
34 Posts
I fixed the flakey oil pressure gauge. I thought it was the sender but it turned out to be a poor connection of the wire to the sender. Easy fix for a change.
 

·
Registered
Joined
·
197 Posts
Replaced radiator, tensioner and idler pulleys. Now my expensive Delo Long Life Antifreeze is staying where it belongs.
 

·
Registered
Joined
·
17,604 Posts
Filled her up and washed her. Going to earn her keep pulling the trailer up to Oregon for a week. Gonna be in my sisters driveway for the eclipse.
 

·
Registered
Joined
·
34 Posts
I replaced the bad ABS hydraulic unit with a new rebuild. Yippee...no more ABS warning light on :)
 

·
Registered
Joined
·
17,604 Posts
I made her work REAL hard. Filled in Redding, drove to Shasta city. 67 miles, used 10.2 gal of fuel @3.00/ga.
 

·
Registered
Joined
·
34 Posts
I need to do that or the sensor....
I tried the sensor first because that is what the internet experts said.

Then my friend Pete told me it is almost always the hydraulic unit because they gum up from poor maintenance.

Pete was right.
 

·
Registered
Joined
·
53 Posts
I tried the sensor first because that is what the internet experts said.



Then my friend Pete told me it is almost always the hydraulic unit because they gum up from poor maintenance.



Pete was right.


Is that the part on the frame under the drivers floor?


Sent from my iPhone using Tapatalk
 
341 - 353 of 353 Posts
Top