The Diesel Stop banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2008 f250 6.4 4x4 that i bought in december of last year.. 103,000 miles. Was running fine till last week i got in to start and it wouldnt turn over.. starter wouldnt engage. dash came on, radio on, but nothing to starter. did some simple troubleshooting than had it towed to dealer. they told me this thing (pic below) was not seated correctly and caused antitheft to disable the truck. Ok.. so i paid my 70 dollars, thanked them and drove home.. started fine for a couple days. 2 days ago i got in to start and same thing. lights, dash came on but nothing to starter. i reseated chip, i moved wires around, tapped on it, nothing.. wouldnt start. jumped in it this morning and it wouldnt start, so i smacked the black thing. not hard, and boom when i engaged the key the truck started. So i have 2 questions. what is this thing and how do i remove, bypass, disengage, get rid of, or generally torch this thing so it doesnt cause me anymore issues.. ford told me it was after market antitheft. can i just remove this thing? and if so , how. ? may end up just taking back to dealer.

Thank you for any replies.


Chad.

20200820_150234_resized.jpg 20200820_150249_resized.jpg
 

·
Registered
Joined
·
217 Posts
You should be able to follow the wires back to where they connect to truck wiring, and then remove it. The wires it connects to may be cut and this is spliced in.

You might be able to cut the piece off and splice those two leads together to do the same thing.
 

·
Registered
Joined
·
1,789 Posts
Hey the same thing was in our suburban when we bought it.
It's just a starter interrupter. Can be hooked up to the fuel pump and pcm.
Basically like said above. You could just remove it and put the wiring back to stock. Or fix the wiring. Probably a crimp splice or bad connection somewhere.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
ya it only has 2 wires coming from it. white one that leads up into the steering column and red one that joins the wiring harness and looks to go up into the firewall.. Does anyone know what brand this is.. it only says "powerplug" on it and has no company markings.. might be easier to work on if i knew what brand it was..

thanx for the replies.
 

·
Registered
Joined
·
1,789 Posts
Only thing mine says is "power plug." Can't find anything on the web.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Sounds like you literally have the exact one I have. yes no information on the Web at all. can't even find a pic of one. well thank you for the info much appreciated.
 
1 - 6 of 6 Posts
Top