The Diesel Stop banner

1 - 9 of 9 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter #1
So this device makes a vibrating / humming sound thats very noticeable in the cab. However, it only does it for a bit then stops. What is this and should I be worried? Its the black box with the orange end or connector on it.
 

Attachments

·
Registered
Joined
·
329 Posts
Discussion Starter #3
Electric Vacuum pump for auto hubs & manual heater controls if equiped
Thats exactly what I thought it might be. Reason being is that last time it made noise was just after engaging 4x4. So why would it be making noise? I took it loose and reassembled it so maybe just wasn't fastened properly. Will engage 4x4 again to see.
 

·
Registered
Joined
·
879 Posts
They will make some noise because it is a pump. Usually you can hear it with the engine off only and key on. If you can hear it with the engine running check for any areas where it may be grounding out and transferring noise. If not, it may be a sign it is going bad. I have replaced a few for being a lot noisier than normal.
 

·
Registered
Joined
·
40 Posts
you have a broken line somewhere. just a rubber tube that somehow split. mine split and was making the humming noise, replaced the tubing (or simply connect each tube with another piece of tube which can be bought at auto zone) and start the truck to get the air out and it will be quiet again. I would bet that is for sure the problem unless the truck hasn't been started for a while. simple fix.
 

·
Registered
Joined
·
329 Posts
Discussion Starter #7 (Edited)
I think and am hoping that it was making noise as it was loose. When I took a look at it I noticed it was almost totally out of its lock position. I realigned it and locked it back in place. So far all is good.
 

·
Registered
Joined
·
1,099 Posts
Have you had to access the fuse box below it lately? Maybe you just didn't get it back in place correctly.
Joe
 
1 - 9 of 9 Posts
Top