The Diesel Stop banner

1 - 2 of 2 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1 (Edited)
OK so these are my issues, truck started to run really bad a few weeks ago...
first problem was my batterey gauge was reading really high then low, found out my alternator was bad...Fixed that.
Next truck would only drive about 20 feet then die and wouldn't restart and if it did it would idle for a second then die again if i let it sit for a while it would start up and i would be able to idle it home. I then checked my fuel pressure and was only getting about 25 psi, so according to other post i went ahead and just replaced the fuel pump, that fixed the pressure issue.
Truck would still only drive 20 feet then die, so the next thing i did was unplug my ICP and truck would drive around my subdivision and not die just shift hard (which i was told was normal) so i went ahead and ordered a new ICP and Pigtail from Tousley Ford. After i installed that truck drove around my neighborhood just fine didn't die or stall or sputter, so i assumed the problem was fixed. I got in my truck this morning to head to work and started to drive, i made it out of my sundivision and as i started to accerlate up to 45 it started to sputter again, the RPMs dropped to zero but the truck never died, then the RPMS came back, so i turned around and went home, and took the honda to work.:sick:

So my question is where do i go next for problems. I have read that it could be the IPR, EBP needs cleaned or the harness under the valve covers. I do not have a scanner to test anything. Any help would be nice. Thanks.

EDIT: I had the CPS replaced by ford on a recall.

Also any one in the Jacksonville NC area that would like to come over and take a look.
 

·
Registered
Joined
·
187 Posts
One way to check for a bad harness at the valve covers is to take off your oil fill cap and smell the inside. If you can smell burnt plastic then you definitely have a bad harness. You could also have a bad cam sensor if your RPM's drop to zero when the engine acts up, even tho you've had it replaced already. Just a couple of things I've had some bad experiences with. Hope this helps.
 
1 - 2 of 2 Posts
Top