The Diesel Stop banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So I decided to change my oil early on my 2002 7.3 turbo diesel. I go to the parts store get two 2.5 gal bottles of oil and went to get a wix OIL filter (only filter ever used on my motor) and they didnt have one. So I grabbed a Motorcraft FL1995. Get home drain oil take off old wix filter and try to spin on the motorcraft. it spins half way up then stops. I take it off try it again no luck. Take it off spin old wix filter on and it spins all the way up. Okay Im figuring bad motorcraft filter. Go back to parts store. no more motorcraft in stock so I grab a K&N filter for my truck (only filter left due to covid bs) and head home. I try to spin up the K&N filter and it only spins up half way ***??? I try the old wix and it spins right up. try the motorcraft nope wont go past halfway. Try the K&N nope only half way. tried old wix spins right up. I CHANGED THE FILTER LAST TIME SO I KNOW IT WASNT CROSSTHREADED OR DAMAGED OR PUT ON WITH GIANT CHANNEL LOCKS OR CHAIN WRENCH. I HAND SPIN ALL THE WAY UP.

anyone ever have this problem?? i took pics of the treads and enlarged them to inspect for anything out of normal and they are fine.I almost took the filter housing off the side of the engine block to try and spin a non-wix filter on it but the gasket and o rings and lower housing cost too much .
 

·
Registered
Joined
·
4,763 Posts
I have not heard of that problem before. Not sure if the two filters are made at the same plant but could be a bad batch. I would find another Wix and try that.
DENNY
 

·
Premium Member
Joined
·
8,936 Posts
The only time that I have had a problem screwing on a filter was after a quick lube shop cross threaded one. After that the last 1/4 inch or so was a beast until the threads cleaned themselves up.
 

·
Registered
Joined
·
4,763 Posts
Did the filter gasket stay on the housing? Take a small wire brush to the threads you may have a sliver of metal off the old filter in the threads.
DENNY
 

·
Registered
Joined
·
1,697 Posts
I only ever had one do that. Spun about halfway, then hard to turn. Figured it was just a fluke.
Post the pictures here.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
I have not heard of that problem before. Not sure if the two filters are made at the same plant but could be a bad batch. I would find another Wix and try that.
DENNY
That is exactly what I did Denny...This morning I took the K&N back to the parts store and picked up a WIX-XP filter for my truck. Told the parts jockey about the filter not spinning on all the way, he looked at me then looked at the filter, then promptly gave me the WIX-XP for the same price I paid for the K&N. I saved 7 bucks.As for the K & N the thread count was incorrect but filter was marked with part# for my truck. Same as the Motorcraft filter right size thread wrong count but marked with right Part#. JUDAS PRIEST WHAT A NIGHTMARE
 

·
Registered
Joined
·
4,763 Posts
Good to hear ya got it fixed!! I have two trucks so I can usually just stop and think about things when I have a problem like that. 98% of the time it is just something stupid I did but every now and then the part is wrong. I have learned to take a lot of pictures and never throw out old parts for a few weeks to make sure things work.
DENNY
 

·
Premium Member
Joined
·
14,748 Posts
The FL-1995 is the right filter so I wonder if someone forced the wrong filter on recutting the threads. I had that happen to my brothers GMC when he took it to a kiwi lube place.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
3 Posts
I have a 99 F550 would 7.3 and I'm having that same problem with the oil filter it spins on about halfway and then stops I got an STP oil filter any other suggestions live in the middle of nowhere to and is my only vehicle
 

·
Registered
Joined
·
1,697 Posts
I have a 99 F550 would 7.3 and I'm having that same problem with the oil filter it spins on about halfway and then stops I got an STP oil filter any other suggestions live in the middle of nowhere to and is my only vehicle
I think that's the same filter I had trouble with. Personally, I just cranked it on. Not saying I recommend it.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
1,430 Posts
I have used the FL1995 filter on my truck for 21 years.....every one has spun on and sealed fine.
 

·
Registered
Joined
·
196 Posts
Google "Chinese counterfeit oil filters" - WOW
 
1 - 12 of 12 Posts
Top